Jump to content

Footswitch double-counting. Hardware fault?


superficialt
 Share

Recommended Posts

One of the footswitches (FS 8) on my Helix Floor seems to be malfunctioning. Most of the time it functions normally, but perhaps 25% of the time it seems to 'double tap' I.e. pressing the footswitch turns an effect ON and then immediately OFF again. On many of my patches, I have it set as the looper and it creates these really short loops (100ms or something at a guess) which obviously sound terrible. It's only that one switch. It's not set to momentary latching or anything. 

 

The unit is a couple of years old, out of warranty I think (I should check). Rarely gigged and not at all in the last year. It's certainly not been abused or got wet or dirty (but I guess dust gets everywhere). 

 

I suspect a hardware fault, but what are the things to try?

 

Software update just in case? 

Compressed air?

Spray some cleaning alcohol in there?

Dismantle the unit and have a look?

Link to comment
Share on other sites

On 7/8/2022 at 11:16 AM, superficialt said:

Most of the time it functions normally, but perhaps 25% of the time it seems to 'double tap' I.e. pressing the footswitch turns an effect ON and then immediately OFF again.

 

Recently I've experienced exactly this on FS3 on my Stomp, too.

 

On 7/8/2022 at 11:16 AM, superficialt said:

what are the things to try?

 

Contact spray was what the guy at my local music store where I bought the unit told me. Did that, it slightly helped for a while.

Other than that, rotating the top of the switch back and forth a few times usually fixed it for the rest of the session.

 

That said, I haven't even experienced it in the past few weeks at all, using the Stomp at few rehearsals, a recordings session and a bunch of live performaces, the last one being a three-hour gig yesterday. So I can't say how it develops. In any case, my unit is still under 2-year warranty for a few weeks, so I may try to have it fixed if the issue should reappear during this summer.

Link to comment
Share on other sites

I've found on both devices that anything less than a FIRM STOMP can result in this behavior.

Not to say that the problem ISN'T caused by dirty contacts, just an observation.

Link to comment
Share on other sites

Yep, it happens, and that's the classical cause of the tap/tempo glitches some people are reporting around threads.

 

Those are not real 3PDT footswitches, but just mechanical FS that stomps against tactile microswitches. So, if you want to clean the thing, spraying against the FS isnt doing anything..

 

You should spray directly against them, which will require a full disassembly (see the video), but IME this works just for a limited amount of time;

 

image.png

 

 

 

  • Thanks 1
  • Upvote 1
Link to comment
Share on other sites

On 7/10/2022 at 1:33 PM, PierM said:

that's the classical cause of the tap/tempo glitches some people are reporting around threads

 

For the record, I've never used the Tap/Tempo function on this Stomp. In fact, that annoyance was the first thing I've turned off for good. 

 

On 7/10/2022 at 1:33 PM, PierM said:

if you want to clean the thing, spraying against the FS isnt doing anything.

 

Thanks for confirming, that's what I've actually suspected as well. But since it usually doesn't do any harm, it was worth a try.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...