Jump to content

POD GO Looper sound quality


kkexplorer
 Share

Recommended Posts

Hey all, 

 

Just recently got the POD GO wireless.

 

I am definitely satisfied with POD go and really like the overall sound.

 

However the looper sound quality is not very good. I plug in Pod go directly to my Blackstar ht20.

If I have no gain or light overdrive the sound is kept in good levels , but If I have a delay or some filters  or more drive the sound

in the overdubs becomes very bad.

 

Have you also experienced that , or do you have any suggestions on how I can improve the produces sound ?

 

Thanks in advance.

Link to comment
Share on other sites

Well, I guess it’s hard to exactly comment without hearing, but if you have an effects-heavy patch, and you start layering overdubs, it can get to sound kind of messy pretty quick. For example, if you’re looping a delayed sound and your loop timing is a little off from the delay repeats, every pass you record on top of the original signal could have repeats that are misaligned with the earlier pass.

 

Many times with looping, less truly is more, as it’s better to layer a bunch of simple part rather a few more complex parts.

Link to comment
Share on other sites

Quote

If I have no gain or light overdrive the sound is kept in good levels , but If I have a delay or some filters  or more drive the sound

 

Think your issue might be that if your Blackstar isn't 100% clean (distortion/gain), so your amp will distort multiple simultaneous sounds and that is why you think the looper is bad quality.  A little bit like with overdrive, a single note sounds relatively clean, but a power chord gets nasty.  So if you're looping multiple samples, you're getting the power chord effect from your amp.  Maybe.  Basically, your amp should be 100% clean, which sometimes isn't the case even when you set the drive/gain to 0. 

 

Being Blackstar, maybe ...  [EDIT]  But looking at the amp, woa, nice tube amp with a clean channel, so that might not be it either.  But tubes, always have some inherent distortion..   What you can also try to confirm if that is your issue, connect headphones to the go and see if you're hearing the same thing when using the Looper.  Headphones is really a quick easy test to do.

 

Otherwise, yeah, as phil mentioned, the more layers you add, the less clear everything becomes; trait of loopers I think, any noise also gets compounded, so if you have any noise, adding multiple layers of it every time just degrades the overall looped sample.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...