Jump to content

Any Cakewalk DAW users getting hangings after Helix v3.5 update....Solved


cumminsn
 Share

Recommended Posts

Hi Forum,

                 At least two of us have reported the same scenario,ie Cakewalk hangs with what appears to be an ASIO comms problem when connecting to any project or trying to create a new one.Reversion to previously functioning v3.15 also doesn't clear the issue,neither does reloading of the v1.97 Driver file or a move forward again to v3.5.

 

Strange thing is that other tools that use the Line6 ASIO driver are working normally,and Cakewalk also works normally with other ASIO drivers,so something very specific to Cakewalk's interaction with the Line6 ASIO driver seems to have happened with the new firmware,and also regressively impacting the previous build.

 

All the ASIO settings in Cakewalk are as before and work fine using other ASIO drivers.

 

Support so far have just suggested going back to v3.15,which doesn't fix the issue,Cakewalk support have referred us to Line6 as they don't test 3rd party hardware,so stuck in a loop now.

 

Any suggestions?

 

Many Thanks,

Neil.

  • Like 2
Link to comment
Share on other sites

On 11/4/2022 at 5:51 AM, cumminsn said:

Hi Forum,

                 At least two of us have reported the same scenario,ie Cakewalk hangs with what appears to be an ASIO comms problem when connecting to any project or trying to create a new one.Reversion to previously functioning v3.15 also doesn't clear the issue,neither does reloading of the v1.97 Driver file or a move forward again to v3.5.

 

Strange thing is that other tools that use the Line6 ASIO driver are working normally,and Cakewalk also works normally with other ASIO drivers,so something very specific to Cakewalk's interaction with the Line6 ASIO driver seems to have happened with the new firmware,and also regressively impacting the previous build.

 

All the ASIO settings in Cakewalk are as before and work fine using other ASIO drivers.

 

Support so far have just suggested going back to v3.15,which doesn't fix the issue,Cakewalk support have referred us to Line6 as they don't test 3rd party hardware,so stuck in a loop now.

 

Any suggestions?

 

Many Thanks,

Neil.

 

Did you remove all Line6 software/drivers before reverting back to 3.15? Did you reinstall the 3.15 version of HX Edit as well as going back to the 3.15 firmware? If that doesn't work maybe reinstalling Cakewalk might work. Might even be worth trying a Cakewalk reinstall after the Line6 HXEdit and firmware 3.50 install/update.

  • Like 1
Link to comment
Share on other sites

Thanks for the response,answer to the first two questions is yes,Cakewalk have also recommended a full delete and rebuild,which I'm holding back from for now given that it works fine with two other ASIO drivers,and three other applications that can see the Line6 ASIO driver also work normally,namely EZDrummer3/Bass/Keys,under both v3.5 and 3.15 Helix build.

 

Evidently something very esoteric going on here,the Helix itself works normally with the new build,in my case it just won't function in the role it was puchased for,ie as a DI guitar source and audio interface,so a quite expensive White Elephant for now at least.

Link to comment
Share on other sites

Hopefully, support will be able to figure this out.

However, it may be a problem with Cakewalk, in which case you're probably SOL.

I say this because I tested the 3.5 ASIO driver with:

 

Ableton Live Lite 11

Cubase Elements 12

Mixcraft 9

Protools Intro

Reaper

 

They all work just fine with the 3.5 ASIO driver.

Only Cakewalk is a fail.

 

I never use Cakewalk anymore, too many problems, but I go way back with it - before Bandlab, before Gibson - when it was called Sonar by Cakewalk. It was my first DAW and while I have a sort of emotional attachment to it, Reaper is just SO much better on every level except eye candy.

 

Do let us know what support comes up with!

  • Like 2
Link to comment
Share on other sites

Interesting. I had the same problem with Cakewalk during beta testing. I contacted Cakewalk support after determining that the problem was not with HX Native because I could not even properly open a New Project in Cakewalk. They guided me through a complete uninstall of Cakewalk, including some Registry edits, and then a fresh reinstall. It works now.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

On 11/4/2022 at 3:37 PM, silverhead said:

Interesting. I had the same problem with Cakewalk during beta testing. I contacted Cakewalk support after determining that the problem was not with HX Native because I could not even properly open a New Project in Cakewalk. They guided me through a complete uninstall of Cakewalk, including some Registry edits, and then a fresh reinstall. It works now.

 

Is there some way we can get to that solution? Especially a list of the Reg Edits. I'd like to try it.

Link to comment
Share on other sites

On 11/4/2022 at 9:51 AM, cumminsn said:

Hi Forum,

                 At least two of us have reported the same scenario, ie Cakewalk hangs with what appears to be an ASIO comms problem when connecting to any project or trying to create a new one. Reversion to previously functioning v3.15 also doesn't clear the issue, neither does reloading of the v1.97 Driver file or a move forward again to v3.5.

 

Strange thing is that other tools that use the Line6 ASIO driver are working normally, and Cakewalk also works normally with other ASIO drivers, so something very specific to Cakewalk's interaction with the Line6 ASIO driver seems to have happened with the new firmware, and also regressively impacting the previous build.

 

All the ASIO settings in Cakewalk are as before and work fine using other ASIO drivers.

 

Support so far have just suggested going back to v3.15, which doesn't fix the issue, Cakewalk support have referred us to Line6 as they don't test 3rd party hardware, so stuck in a loop now.

 

Any suggestions?

 

Many Thanks,

Neil.

Well, I have literally just finished doing exactly what you have already done. All I am able to confirm is what you already know - it didn't work with rolling everything back. My findings are just the same as you have already found out.

 

On 11/4/2022 at 9:37 PM, silverhead said:

Interesting. I had the same problem with Cakewalk during beta testing. I contacted Cakewalk support after determining that the problem was not with HX Native because I could not even properly open a New Project in Cakewalk. They guided me through a complete uninstall of Cakewalk, including some Registry edits, and then a fresh reinstall. It works now.

This could be my next move, when I have the chance

 

Link to comment
Share on other sites

On 11/4/2022 at 6:25 PM, rd2rk said:

 

Is there some way we can get to that solution? Especially a list of the Reg Edits. I'd like to try it.

I would open a support ticket with Cakewalk. I use the Cakewalk by Bandlab product and don’t know if the instructions I received would work with other Cakewalk products.

Link to comment
Share on other sites

@cumminsnPer L6 @jamesdom over on TGP, uninstall the ASIO driver v1.97. Assuming that v1.96 is still installed, when you reconnect Helix (have to disconnect to uninstall) v1.96 will load and Cakewalk will run as expected. I just tried it, works great! Bug reported, they're working on it.

  • Like 1
  • Thanks 2
  • Upvote 1
Link to comment
Share on other sites

On 11/5/2022 at 3:49 AM, rd2rk said:

@cumminsnPer L6 @jamesdom over on TGP, uninstall the ASIO driver v1.97. Assuming that v1.96 is still installed, when you reconnect Helix (have to disconnect to uninstall) v1.96 will load and Cakewalk will run as expected. I just tried it, works great! Bug reported, they're working on it.

 

Thank you for the tip ,  but how do you do that?

 

  • Like 1
Link to comment
Share on other sites

On 11/4/2022 at 12:20 PM, rd2rk said:

However, it may be a problem with Cakewalk, in which case you're probably SOL.

I say this because I tested the 3.5 ASIO driver with:

 

Ableton Live Lite 11

Cubase Elements 12

Mixcraft 9

Protools Intro

Reaper

 

They all work just fine with the 3.5 ASIO driver.

Only Cakewalk is a fail.

 

^^^^ THIS ^^^^

.... is exactly why I left the Cakewalk/Sonar platform 10 years ago

 

Sure, this may be a legit problem with the L6 driver, but it always amazes me that Cakewalk/Sonar is the first one to fail, and fail miserably in these cases. 

  • Upvote 1
Link to comment
Share on other sites

  • cumminsn changed the title to Any Cakewalk DAW users getting hangings after Helix v3.5 update....Solved
On 11/5/2022 at 1:44 PM, cumminsn said:

v1.96 driver has fixed the issue,here at least.Thanks to everyone who contributed to this thread,much appreciated.

 

Neil

UK

Neil,

I see you say that v1.96 driver has fixed the problem but are you operating Helix firmware v3.5 or is that rolled back also?

 

Link to comment
Share on other sites

On 11/5/2022 at 3:18 PM, RGBargie said:

Neil,

I see you say that v1.96 driver has fixed the problem but are you operating Helix firmware v3.5 or is that rolled back also?

 

 

No need to roll back from 3.5, just the driver.

Link to comment
Share on other sites

Late reply...sorry...just the v1.96 driver fixed this,with the new 3.5 build and HX Edit at 3.5 now working fine.

 

I guess we await a v1.98 driver soon.

 

For any fellow Cakewalk users(and I need to read up on this if it affects interaction with the Line6 ASIO driver)...the next Cakewalk update 2022.11 doesn't set MMCSS as default,so it needs to be manually selected in the Preferences section.Slightly off-topic but just in case things go out of whack again.

 

Once again,many thanks to everyone who helped here,I now look forward to some Peavey Invective and new cabs.

  • Like 1
Link to comment
Share on other sites

Thanks, just getting round to confirm fixed no

On 11/6/2022 at 4:57 PM, cumminsn said:

Late reply...sorry...just the v1.96 driver fixed this,with the new 3.5 build and HX Edit at 3.5 now working fine.

 

I guess we await a v1.98 driver soon.

 

For any fellow Cakewalk users(and I need to read up on this if it affects interaction with the Line6 ASIO driver)...the next Cakewalk update 2022.11 doesn't set MMCSS as default,so it needs to be manually selected in the Preferences section.Slightly off-topic but just in case things go out of whack again.

 

Once again,many thanks to everyone who helped here,I now look forward to some Peavey Invective and new cabs.

All good, same here. Working with rolled back driver v1.96. Cheers - and same...playing with the invective atm 

Link to comment
Share on other sites

I'm having the same problem. I updated to Helix 3.50 and cakewalk hangs when trying to record or load projects. The problem seems to be with HX Edit rather than the firmware.

How do I roll back the cakewalk driver to 1.96? If I uninstall and reinstall, will I lose all of my projects and recordings? Audacity works fine, but I'm used to Sonar and Cakewalk, and have been using this for years. Thanks.

Link to comment
Share on other sites

On 11/10/2022 at 5:45 PM, Veneficuous said:

I'm having the same problem. I updated to Helix 3.50 and cakewalk hangs when trying to record or load projects. The problem seems to be with HX Edit rather than the firmware.

How do I roll back the cakewalk driver to 1.96? If I uninstall and reinstall, will I lose all of my projects and recordings? Audacity works fine, but I'm used to Sonar and Cakewalk, and have been using this for years. Thanks.

 

You will not be rolling back the "cakewalk driver". You will be rolling back the Helix 1.97 driver to 1.96. Available from the Line 6 download page.

Link to comment
Share on other sites

On 11/10/2022 at 6:44 PM, Veneficuous said:

I changed the settings on cakewalk preferences/playback and recording to Wasapi exclusive instead of Asio. Playback and recording works now, but what's the difference between Asio and Wasapi? Am I losing audio quality doing this?

 

Pretty good article comparing ASIO and WASAPI.

 

WASAPI vs ASIO - The Audio Driver Stack Recommended by EXPERTS! (performerlife.com)

  • Upvote 1
Link to comment
Share on other sites

On 11/10/2022 at 4:44 PM, Veneficuous said:

I changed the settings on cakewalk preferences/playback and recording to Wasapi exclusive instead of Asio. Playback and recording works now, but what's the difference between Asio and Wasapi? Am I losing audio quality doing this?

 

On 11/10/2022 at 4:50 PM, HonestOpinion said:

 

ASIO vs WASAPI bottom line:

 

If you're playing live (in real time) through a plugin (such as Native) use ASIO for minimum latency.

  • Upvote 1
Link to comment
Share on other sites

On 11/12/2022 at 6:01 AM, kzmaier said:

I rolled back to 1.96 and still have the same problem.  I also updated Cakewalk to the 11/2022 release.  I also set the MMCSS to enabled.  No go.

 

Is the rollback to 1.96 working for everyone???

 

Check in Settings>Apps&Features. If 1.97 is still there, uninstall it.

Link to comment
Share on other sites

Just closing Cakewalk, unplugging the Helix, then as @rd2rksays going to Settings>App&Features and uninstalling the 1.97 driver version (you'll notice that older drivers are still there, so there's no need to search for them on the net and installing them), and finally plugging the Helix back again and restarting Cakewalk worked for me like a charm. No need to reboot.

Link to comment
Share on other sites

On 11/13/2022 at 11:45 AM, chusx said:

Just closing Cakewalk, unplugging the Helix, then as @rd2rksays going to Settings>App&Features and uninstalling the 1.97 driver version (you'll notice that older drivers are still there, so there's no need to search for them on the net and installing them), and finally plugging the Helix back again and restarting Cakewalk worked for me like a charm. No need to reboot.

 

Am I the only one still not able to get this working? Reverted to 1.96 and still have Cakewalk hanging.....

Link to comment
Share on other sites

On 11/16/2022 at 12:05 PM, IMC1980 said:

Can't do anything in Cakewalk on the Stomp.

 

Be more specific. The problem being addressed was that Cakewalk would "hang".

Is that what's happening?

If 1.97 is completely off your system, you could try re-installing Cakewalk.

  • Upvote 1
Link to comment
Share on other sites

I also ran the 1.97 driver uninstall and re-ran the 1.96 driver installer but still had the problem.  When I checked the 1.97 driver was still installed and being used as the HX Stomp driver.  I created a support request to Line6.  Waiting for a reply...

Link to comment
Share on other sites

As indicated in my Nov 4 post above this may actually be a Cakewalk issue. After contacting their customer support and following their instructions I now have Cakewalk by Bandlab working properly with Line 6 driver v1.97.

 

Caveat: I am using Helix Rack not Stomp, and I encountered my issue with attempting to use Helix Native.

Link to comment
Share on other sites

On 11/17/2022 at 8:19 AM, kzmaier said:

I also ran the 1.97 driver uninstall and re-ran the 1.96 driver installer but still had the problem.  When I checked the 1.97 driver was still installed and being used as the HX Stomp driver.  I created a support request to Line6.  Waiting for a reply...

 

Did you do the uninstall from Windows>Apps and Features?

Link to comment
Share on other sites

  • 3 weeks later...

Line6 has released a new driver (v1.97.0.2) which fixes the issue with Cakewalk. You can download it from Line6 website, but it's also installed with the new HX Edit v1.51.

 

I hope this new driver fixes the problem for everyone.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...