Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Helix/HX Edit Issue - Nothing Happens When I Click "Create Backup" in HX Edit


Recommended Posts

I bought a Helix a while ago and I have been very slow at building any presets.  I tried to make a couple quite a while back but was having some issues figuring out how to do a lot of things.  Long story short, I recently updated the Helix and HX-Edit Software to version 3.5 and decided to take another stab at trying to figure out how to do some things on it and I created a few patches and thought it would be a good idea to back it up but when I click "create backup" in the HX Edit software, literally nothing happens, no prompts, no nothing. 


I am running a PC with Windows 11.

I completely uninstalled the HX Edit software, rebooted and reinstalled, no go. 

I read someone said they were able to create a back up when they ran HX Edit "as administrator" so I tried that and same thing, no go. 


Is there any other way to do a full backup or does anyone have any other suggestions?

Link to comment
Share on other sites

On 12/29/2022 at 12:09 PM, silverhead said:

You can make backups of individual presets by drag/dropping them from the HX Exit window to a folder on your computer.


Creating a full system backup is an issue that needs resolving but in the meantime you can backup individual presets. 



Is there a specific set of circumstances around this? My backups seem to work fine.

Link to comment
Share on other sites

On 12/29/2022 at 2:38 PM, rd2rk said:


Is there a specific set of circumstances around this? My backups seem to work fine.


The only thing I did was updated to 3.5 firmware and latest version of HX Effects.  I wrote a couple of patches and tried to "create backup" but nothing happens.  Everything else in HX Edit seems to work fine.  Used the software to create the patches and switch stuff without issue.  Like I said, tried uninstalling and reinstalling the software.  But I click create backup and nothing happens.  No pop up box, no nothing.  I have an old, laptop I'll give it a try on but the one I've been using it with is a brand new Dell purchased within the last year.  Have no other issues with anything else.  Latest patches, etc.  Just weird.  I found a couple other posts online from others having the issue but what there was for suggestions didn't work for me.

Link to comment
Share on other sites

Start fresh!

Begin by using Win 11 File Manager to backup any custom Presets you may have created if you wish to preserve them.

Then uninstall all of your Line 6 software from your PC.

Next download from the Line 6 website a clean full copy of HX Edit 3.51 which is the most current version (released Nov 29, 2022) for Win 11.

Launch this and allow it to install all the components to your PC.

When completed connect your Helix to your PC and launch HX Edit. Confirm that it shows HX Edit 3.51 is running, and confirm that your Helix device is running 3.50 which is the latest version of the device firmware. If HX Edit prompts you to install 3.50 firmware to your Helix device, allow it to do so and follow the steps precisely. One of the steps will be to perform a Backup.

At this point, you should be able to use HX Edit to do a Backup of your device.

Regardless of the above steps, it is a wise idea to perform a Power On Factory Reset of your device. See for the Reset Options for your Helix device. 

Should you wish to Restore any of the Presets which you may have backed up using Win 11's file manager, or subsequently using HX Edit, it is important that you perform the Power On Rebuild Presets to assure any Restored Presets properly conform to the latest version firmware and HX Edit. Again, see for the Reset Options button combination for your device. 


Hope this helps. 

Happy Holidays. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...