Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Helix LT And Studio One 6 Pro - Audio Distortion


Recommended Posts

Hi Forum,

                This is a somewhat back to front assistance request,as the Line6 Support team would probably(with some justification)point me to Presonus,whom I'm still waiting to respond having raised a ticket two days ago.


Recently purchased my first paid DAW since 2006,having used SONAR and CbB since then.The choice was 50/50 between Studio One 6 Pro and Cubase 12 Pro,so decision was to go with S1 Pro.


Having set up the app and connected it to my Helix ASIO driver,a simple one track audio project created as a test gave immediate severe playback distortion,even at a buffer size of 2048 samples.Various other projects with pure audio,VST instruments and a combination of both also behave the same way.


The solution to the problem per project is to open the audio settings window and temporarily change the Device Block Size to a lower value,apply this,then revert to 2048 again,which then gives undistorted playback.This has to be done each time I move between projects.


The issue doesn't occur when connected to my Focusrite Scarlett interface,so evidently some interworking problem between the Line6 ASIO driver and S1 6 appears to exist.


My DAW machine is quite high spec and there is no CPU or RAM challenge,plus the Helix works without issue on Cakewalk.


While waiting for Presonus to respond...are there any forum users who use a combination of Studio One 6 Pro and a Helix,who have either encountered the issue described or have any suggestions as to troubleshooting or mitigation,as it has currently rendered an expensive purchase problematic to use.


I have reinstalled the latest Line 6 v1.97.0.2 USB driver without any improvement.


OS is Windows 10 20H2.


Many Thanks,



Link to comment
Share on other sites

On 1/6/2023 at 5:23 AM, cumminsn said:

The issue doesn't occur when connected to my Focusrite Scarlett interface,so evidently some interworking problem between the Line6 ASIO driver and S1 6 appears to exist.


Happy Studio One 6 user here. To be honest.... I always use a dedicated audio interface and never have an issue. Your Scarlett works fine... I'd just stick to that. I know that's not much help.... I just find the efforts are not worth the trouble when there is a solution already at your fingertips. The wait for a fix could take a long time. 


On 1/6/2023 at 5:23 AM, cumminsn said:

Helix works without issue on Cakewalk


There have been a few threads of users having issues with the current audio drivers. Ironically, those were Cakewalk users which you say works fine... go figure. Their fix was to "downgrade" the Helix audio driver, not the firmware. Perhaps that will also work in your case with Studio One? 

  • Upvote 2
Link to comment
Share on other sites

Thanks for the reply Codamedia,the Scarlett is already plugged in...


Correct in para 2 as well,as the 3.50 firmware rollout with the v 1.97 USB driver caused us Cakewalk users to hang,so the workaround was reinstalling v 1.96,until the

recent update to v


So for now,it's back to tracking guitar through Cakewalk and upskilling in Studio One for the mixes.


Much Obliged!



Link to comment
Share on other sites

Hi, long time Studio 1 & Helix user. I'm pretty sure I've done some recording with no issues since the 3.5 update, but will have a look over the next couple of days and let you know, along with any settings.

  • Like 1
Link to comment
Share on other sites

No issues my end. I tried recording at all four available sample rates, changing it in Studio 1 and the Helix followed flawlessly. It also played back existing tracks/songs fine.


My audio settings for 48k recording and song settings attached, but they're nothing special.


My line 6 driver is V, the Floor is on FW 3.5, Edit is 3.51, Windows is Win 10 Pro Windows Feature Experience Pack 120.2212.4190.0.


Whilst my default sample setting is 2048 samples (I always monitor the affected sound direct from the Helix), I could drop it to 256 with no playback issues.


However, I opened a song with a single stereo track I was mastering using Helix Native, and it distored@1024 which was the project settings. Once I changed to 2048, I could drop it back to 64 samples with no issues. One thing to note is I haven't updated Native for ages, and I can't for the life of me remember how to show the version number.


Sorry, I don't think I've helped at all.



Link to comment
Share on other sites

Hi Waymda,

                     Very detailed assistance,above and beyond,so big thank you.


Just to complete the picture,could you please advise what your settings are in the Processing tab,ie Dropout Protection value,Process Block Size,Process Precision and if you're adjusting these to utilise the Green Z to invoke Low Latency monitoring?


I typically use 44.1 kHz 24 bit,so may experiment with 48 kHz and see what happens,still some very strange behaviour happening.Latest finding was creation of a single stereo track song and imported an existing audio file recorded at 44.1/24 and this worked fine again and again at 2048 samples...until carrying out a Track Transform,the playback of which was then distorted.The even stranger part was then rolling this back to Realtime and the distortion disappeared again.


The behaviour is quite random so really no idea what's going on,seems we have the exact same build on the Helix and Helix Edit,and the same level of driver,so that makes the troubleshooting more tricky.As mentioned,no issue at all with my Scarlett so definitely some interworking problem with either the Helix itself or the Driver.


PreSonus have responded to the support request,so diagnosis ongoing.


Many Thanks for your timely help.




Link to comment
Share on other sites

Hi Neil


Processing tab below. I don't recall ever changing anything on this tab, but I've been using Studio 1 since V2, so may well have a long time ago. Apologies about the quality, the forum is refusing any file larger than 42.4 kbs - just weird.


I just had to look up the Green Z so we can safely assume I don't use it. However, as mentioned I monitor direct from hardware. I've never had the need to hear DAW procesed tracks when recording, so my use case is likely different to yours. I use a DAW more like an old school tape machine with advanced editing abilities and post tracking processing abilities.


I do recall on earlier versions having some real issues with mix rendering, but that issue went away around V3.x, and I no longer even maintain a specific boot optimised for audio (which i used to have to do), as both hardware and OSs and drivers seem to have their act together theses days.


I could only suggest full uninstalls and reinstalls of the Helix drivers to see if that helps - a manual removal through Device Manager would be the most thorough. Checking the USB port and/or cable may assist - L6 gear is notoriously finicky about USB, and I have had issues in the past with specific cables and ports so once I sort that out for a hardware combo the Helix gets its own dedicated cable and port.



Link to comment
Share on other sites

Thanks for your valuable time Waymda,that lot should keep me quiet for a day or two while PreSonus take a look at my MSINFO32 file.


Always very hard to troubleshoot this type of random issue,especially as I have two other applications using the Helix ASIO driver without any problem.


I'll report back with any progress or result,as hopefully other users may benefit.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...