Please ensure Javascript is enabled for purposes of website accessibility Jump to content

v3.60 and MacOS El Capitan 10.11.6


Recommended Posts

The bad news:

Autoupdate from within HX Edit may not work, it may display "No update available".

This is not unexpected though, there are barely any apps whatsoever that still get any updates compatible with El Capitan (one noteworthy exception being the brilliant audio tagger Yate!)

According to the Line 6 documentation, MacOS Sierra (10.12) or higher is "required". While that was already their message for earlier updates, this time it's apparently for real.


The good news:

HX Edit 3.60 can be installed manually and it still runs on El Capitan!


The caveat:

Firmware 3.60 is shown as "not available" via HX Edit 3.60 on El Capitan anyway. 


The workaround:

Line 6 Updater may still very likely do the job on El Capitan directly, but I didn't test it.

Instead, I booted my Mac from a Catalina (10.15.7) partition. The built-in updater then worked as expected from within HX Edit.


The result:

Back in El Capitan, HX Edit 3.60 can still manage my connected Stomp with firmware 3.60 as usual. Yay! :)


Your mileage may vary.

Link to comment
Share on other sites

On 4/26/2023 at 1:30 PM, lou-kash said:

I booted my Mac from a Catalina (10.15.7) partition. The built-in updater then worked as expected from within HX Edit.




I'm running Catalina (10.15.7) and my installed version of HX Edit detected the update and started to download the new HX Edit v3.6, but at about 70% it stopped and said it would launch a web browser for me to manually download the editor. I did that without issue and installed HX Edit 3.6


I opened up HX Edit 3.6 and once again the pop up said the new firmware was available, so I clicked on the green update now button. Once more it went into the downloading routine and then stopped with the message "HX Edit  Failed to download firmware update file. Please check your internet connection and try again. Unknown Error. [code -2004].


First time I have ever had this happen, so will do a local install with the updater while disconnected from the local network and internet. Possibly a busy server issue, but never had this in over 7 years of updating. Strange!



Offline local install worked perfectly - up and running v3.6

Edited by datacommando
Added note
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...