Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Fx Loop quit working


Recommended Posts

I was setting up my Pod Go with a new (old) Fender Super Amp (really nice old Fender sound!!), and was trying to put some drive pedals into the effects loop of the Pod go (there is no Fx loop in the Fender).  It worked fine, then after I plugged the Pod Go into my computer to set up a new pre-set, the effects loop quit working in all pre-sets.  I tried everything, swapping cables, go in and out in all the combinations I can think of.  Everything works great in the Pod Go, EXCEPT the effect loop - which does not work in any pre-set.

While it is possible something broke (there was no indication via crackling sound, broken transmission etc.)/bad circuit board, I suspect some setting got changed by accident.  I tried to set it back to factory settings and it did not work.

Any suggestions of any kind?  I really need to get the Fx loop working!!

Thanks all.

Link to comment
Share on other sites

You can try plugging a single patch cable in the FX Loop out -> FX Loop in of the Go.  If it doesn't work, try with a different cable.  If you get any sound, the issue is elsewhere.


You can check the FX Loop settings in the manual, page 24.  You also have page 32, Fx loop level in global settings -> ins/outs

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...