Jump to content
Sign in to follow this  
Cozz33

Spider Iv 75 Watt Makes Crackling Noise When On High Gain And Drive.

Recommended Posts

Hi, I've noticed a slight crackling noise when I play with high gain and drive, most noticeable when on the insane setting. Clean channels are fine. The noise is very slight and really doesn't bother me. My question is should I be worried about this? Will playing on the metal and insane channels break my amp?

Share this post


Link to post
Share on other sites

I doubt the noise could hurt the amp, however you should try to figure out what is causing it.   Have you downloaded the updated Fusion firmware and installed into the amp?

Share this post


Link to post
Share on other sites

To update it you need the foot pedal right? I spent all my money on just the amp a few days ago. Thanks for responding!

Share this post


Link to post
Share on other sites

Sounds like you may be experienceing digital clipping. Does it go away when you back off the drive a bit? You don't need the foot pedal but it is a very nice option for sure. Try honing in on your tone, lower the drive and volume and work your way back up.

Share this post


Link to post
Share on other sites

Yes I don't hear any crackling when paying through clean channels. Is this damaging my amp? 

Share this post


Link to post
Share on other sites

Yes I don't hear any crackling when paying through clean channels. Is this damaging my amp? 

 

I don't think it's damaging your amp. It just doesn't good. You said your clean channel sounds ok and that's cool, but you should go back to the channel "insane" or "metal" and try to hone in on a good tone without the clipping. Try adjusting the gain and volume to get a good dirty tone without that noise your hearing if you can't maybe something in the amp vibrating especially if your playing at high master volumes.

 

Come to think of it I don't think you run those channels with the gain at max without clipping.

Share this post


Link to post
Share on other sites

Did it work man ? I am getting the crackling noise too,I am thinking the Spider II is superior to the IV on the green insane channel??

Any way to rectify the crackling on green insane on the SPIDER IV would be a God send.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...