Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Recommended Posts

Wasn't sure what topic to put this under, but I've had this Backtrack + mic for about 2 or 3 years now.

The battery won't charge anymore when I plug it into my USB port on my MAC. It used to charge fine a few months ago, I haven't used it in a while.

The battery is dead, but it won't charge. Upon plugging it into the USB port, I turn the switch on to the middle notch. It turns on with the white light, then it flickers red and orange--indicating that it's dead. Then it turns off. It won't charge even though its properly plugged in! 




Does it need a new battery???

Link to comment
Share on other sites

Hi Melly_Rock,



   I don't know anything about the Backtrack, but I have had a bit of a look and I saw that someone said their backtrack needed a usb charger to charge it and not a computer usb port.

As you said, you know it works with a computer ( as this article also makes clear ), so maybe there is some computer setup problem causing this - ie why this other person couldn't get it charging from a computer. I am not a mac expert but I know that on pcs, usb ports can be chosen to share power etc and also sometimes one port is better than another. I'm sure you've probably tried the possible ports though. Do you have any other devices that charge from computer ports? Are they charging ok?


Sorry I can't help you much.


If you haven't tried already, maybe you could go to this page and contact the technical support people:


Hopefully someone can help you out. It's never nice to have to just think it must have died. Even if it has, there might be an electrician who might be able to fix it.


God Bless,


Link to comment
Share on other sites

  • 3 weeks later...

I bought Line6 Backtrack today. Read instructions and have had it on charger for more than 6 hours. The charging light remains red with a very very slow red pulse.

My computer sees the files on the device and the software works.

It seems the unit doesn't complete charging. Does that mean the Lithium ion battery is faulty?

If so, how do I get a replacement unit? I live in Auckland, New Zealand

Link to comment
Share on other sites

Hi porkef


   I'm not sure if the battery might be losing it's charge. If you haven't tried already, try totally using up the battery life and then recharge and see if that makes any difference.

It could be that the battery is losing it's ability to fully charge though :(  I haven't found any web pages which provide a source for batteries, but I found a page on the internet that describes how to install a new battery.


You might have already seen that site.


I saw a 2009 post on line 6 where someone from Line 6 said that they didn't have a way people could replace the batteries but that they might provide a way in the future.


Do you know the product name / number of the battery?


Hope you can find a way to get it working how you'd like.


God Bless,



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...