Jump to content

Monkey And Manual Install Of Latest Ux1 Driver Failing

Recommended Posts

I had Pod farm 2 and others working after installing the latest UX1 driver, but today I see after running latest monkey software that it has reverted back to the older UX1 driver, and it may have never installed before, not sure.


The only thing is that the driver installation process shows everything installs and completed, but it still didn't actually update. Now I went into windows control panel for hardware and checked the driver and I manually tried selecting the newest driver version and I see it says the new driver version isn't supported on my platform so it wouldn't let me install it.


Ill see if there is an issue with unsigned drivers  and disable that if it is the reason.this system running win7-64, but monkey downloaded the file automatically, and I manually downloaded it with the same result... I assume I did grab the right file.. I thought I had already disabled windows from blocking unsigned drivers, so I don't think that is it, I'll keep looking..


Anyone else seen this happen on Windows 7 64 bit before?


Link to comment
Share on other sites

have you tried a different usb port?

i've seen a few rare cases where it only ever updated when the port was changed... like it holds that driver because it's in use...

at least that appeared to be the case.

Link to comment
Share on other sites

Just tried that, and tried the faster USB 3 port but it still shows the older ux1 driver is installed, and installing with the newest update installer still fails too update. I think I am going to wipe :C/ and install some other OS


 Also booted windows with enforcement of digital signing turned off but it still won't install, so I'm wiping the drive..


Installed win7 32 bit and now it all works fine.. everything installed without any issues. seems 64 bit has issues a lot with about everything sometimes..


I have sound coming through nicely with Pod farm 2, but just need to route monitoring so there isn't latency, all for tomorrow.. I'm glad I was able to help myself fix this.  I think the empathy from unknown sources probably helped too..

Link to comment
Share on other sites

Everything with the UX1 worked fine last night, and today I boot up everything and see that after installing gearbox which I only installed since it showed up in list, and ran it, and it worked, but hung after running, so I rebooted machine and now it say's that the old driver is installed again and nothing works again? I bet this has something to do with all the anti theft protection written in to the software and eeproms on device..

Any suggestions would be appreciated.

I probably should not have installed gearbox

I don't get why this would force the device to revert to old drivers..

And now the latest drivers wont install, what the heck is that all about.

Link to comment
Share on other sites

Thanks for reply,,,


I did manage to get it working and it turns out was a simple mistake on my part, which was leaving the UX1 plugged in,  I had began installing Gearbox since it was available without considering that any installs for these devices also have the drivers packed in with them, and so it over wrote the drivers already installed with old ones or something..

Any way, I just uninstalled everything and started fresh and waited for prompting before plugging in the interface and all is solved now.


I also got a "Y" cable with 2x -1/4" jacks for putting into the UX1 "analog outs right and left) and then it has a 3.5mm jack on the other end which I plugged into the "microphone jack" on the sound card, and after setting the sound card "mic" mixer control to "MIC" instead of "Line In"   it started putting out the monitoring sound  without any noticeable latency and the tone direct control knob on the UX1 works perfect with that configuration....


So it seems all is working good, however, I was curious if anyone has ever used a S/PDIF connection from computer sound through a little S/PDIF to analog converter box and using that to connect to the UX1 , as I was thinking it would have a bit better quality sound , but maybe that would only be important if it was for the recording signal, so I think maybe that wouldn't matter..


Just wondering if anyone has used a setup like that and found it useful.. It is difficult to find rigging methods to try since there are so many ways to go.. I'll just keep checking and reading up on it....


Thanks again.... :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...