Jump to content
  • 0

Pod Xt Pro, Patch Editing Does Not Work!



my problem is that the buttons:


all the selection buttons on the bottom side of the display

do not work!

simply the Tune system button does work.

Now it can't be that all the buttons are broken, there has to be some other issue.

I've bought the device from a friend which had it connected to his computer. At his place those buttons DID WORK.

Now can it be that somehow, because he used the editor software, the device disabled those buttons and got stuck in that mode?

Also when I try to reflash the USB firmware, it says that it failed to authorize the firmware.


Share this post

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

If you have tried all of the above and it still doesn't work. You "could" try opening it up and seeing if the display (daughter board) ribbon cable worked itself loose and may need reseating. Just an idea prior to seeing about taking it in for service.

Share this post

Link to post
Share on other sites
  • 0

I owned a Bass Pod (non-XT), where after about 2 years I couldn't edit ANYTHING, only could go through factory presets.  Took it to an authorized repair shop & they said it would cost roughly $120US, & didn't guarantee it would fix the problem.  I bought a new Bass PodXT instead, no problems after several years & more, better sounds overall. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now