Jump to content

Recommended Posts

Hey, so my DL4 cut out the other day and I've opened it up to find that batteries have exploded and leaked acid all through the pedal. The circuit is pretty burnt and it won't start at all. I've only ever run it off a line 6 official power supply. And am always super careful with the unit.

Has anyone else had any problems like this? 

Also, being based outside of Europe, or the USA. There is no number or emailing address for me to get in contact with line 6 about the issue. If anyone could shed some light on where I can get in communication about customer support, that would be fantastic!

 

Love the DL4, I just want to get it revived :( 

post-1995590-0-11612100-1405598786_thumb.jpg

Share this post


Link to post
Share on other sites

Do you have any idea how long the batteries were in there? It doesn't matter all that much, but leaving dead batteries in a battery compartment will eventually cause them to leak (the stuff the leak is potassium hydroxide, which is actually a caustic agent, not an acid).

 

I guess the best case scenario is that the leak just caused a short and caused the unit to stop working that way. If that's the case, cleaning everything up may fix it. The worst case is that the board itself is damaged in some way. I'd say try cleaning it up as best you can and go from there. You probably want to wear rubber gloves while cleaning it up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...