Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Pod 2.0 - troubleshooting no output

Recommended Posts

I got a very sweet deal (next to nothing) on a used POD 2.0.  The guy I got it from told me
"it didn't work," but since I was handy with repairing things, I decided to take it anyway.

The behavior is as follows:
It powers up fine, seems to go to the last selected preset, and recognizes input from my guitar, meaning I can use the tuner just fine.  The problem is that there is no output whatsoever, from either the phones jack or the left or right outputs.

This unit did not include a power supply when I received it.  The aftermarket one that I purchased
is input - 120VAC, output - 9VAC 1500mA.  It is not the official Line6 model, but it does output AC and not DC.  Because it didn't have a power supply, I can only assume that one of the previous owners (at least two different people) tried to use an incorrect power supply at some point.  

Most everything on the board looks okay - with the exception of some dull looking joints for the power plug.  Any idea on how to proceed from here?  I am semi-experienced with surface mount components so I can replace stuff if necessary, but I'm a newb with troubleshooting unless it is something painfully obvious.  I'd really like to use this dude for recording since my main amp is out of service at the moment.



Link to comment
Share on other sites

Hey there, well it could be a variety of things.


Do you know what version Pod it is? is there a "FBV" printed at the top (above the display)? If so you may try reflashing the memory. The L6 Software page has the flash memory listed. If not it could be using the old eprom which I don't know where you could get one. -> in case something got corrupt in the system memory.


If it is getting an input but no output - first thing I would check would be the output jacks. Solder joints and such.


Power supply should be 9AC @ 2,000 mA btw.


Hope you get it going!


Link to comment
Share on other sites

Thanks for the response Bill!


Unfortunately, I did not see the "FBV" anywhere on the unit, so I guess it's a previous version.  My Line6 EPROM IC is version 2.2 (although not sure if knowing that helps anything).  I did go ahead and check all of my output connections by testing continuity from TS/TRS plugs to the board...they all looked okay.  I'm going to guess that maybe my EPROM got fried somehow, but I don't know that for certain.  Any clue if there is a supplier somewhere that might have some of these chips?  I read that Line6 has long since run out of stock, but quick searches on popular search engines didn't turn up anything for me on my end.  That being asked, I don't know for certain that IC is the problem...I'm just shooting the dark here.


On the power supply, I can see that the official Line6 model is 2000mA, but on the back of my unit, it says "1200 mA minimum."  It looks like there are several power supplies sold on Ebay that are marketed as "POD 2.0" power supplies that are 1500mA like the one I purchased.  I guess what I'm wondering is, assuming I get this thing working, would I notice any type of sound disadvantage by using the 1500mA supply?  Could it also be that because I don't have the 2000mA supply, there is just not enough power available to output sound?  Any idea on what these things actually draw?  I'm looking at picking up one of the official Line6 supplies, but because I'm not certain what is wrong here, and I'm nearing to being broke as usual, I'm being hesitant about picking one up. 


Thanks again!

Link to comment
Share on other sites

i think you should have an output signal from the pod even with the lower current capability of your ps. since it's old, i would try changing the battery. you have to open it up and do some soldering. it doesn't cost much and you can also check stuff on the board. remove the knobs using 2 small screwdrivers to pry them up using even pressure on opposite sides. protect the finish. they can be a lollipop to pry,

Link to comment
Share on other sites

Thanks again for the reply.  So, I've got the battery off of the board, but the contacts are somehow mated to the battery.  I'd like to know how the battery contacts are attached to the battery prior to doing "anything stupid."  I read in another post they were riveted into the surface.  Is this true, or can I just heat the battery up with my iron and the contacts will come off?  I could just go ahead and try it but I'd prefer not to destroy the contacts if that's not the correct way to do it. 


It's kind of ridiculous the original designers didn't use a standard coin battery holder, but I'm sure it was more of a "forcing you to have it done by an official tech" thing...either that or a cost saving thing.  Since my unit is wasted and it's basically up to me, I'd like to know how to do it.  I'm still not sure the batt is the problem, as the previous preset comes up upon powering, but I'm willing to try anything if it could be something as straightforward as that. 

Link to comment
Share on other sites

  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...