Jump to content

KB37 and Logic Pro X - some keys not working


Recommended Posts

I am using a Line6 KB37 together with Logic X 10.0.7 (OS X 10.9.4). The KB37 (newest drivers and firmware) is my audio in- and output and midi device. Everything works fine except two keys on the KB37 which are not triggering sound (e. g. as a software instrument). It's F3 and B3. Instead of triggering sound some weird movement on the faders are happening. I can trigger those two tones without a problem drawing them into piano roll. Also GarageBand has no problems at all triggering every tone on the KB37. It clearly seems to be a Logic Pro X problem. And my Roland FP-7 masterkeyboard (also connected via USB) triggers all midi notes correctly, too. It very much seems to be a midi-misunderstanding between the KB37 and Logic, but I have no idea where I can map the KB37 correctly. 

 

Any ideas how to solve this annoying problem are more than welcome.

 

Thanks,

 

Marc

Link to comment
Share on other sites

  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...