Please ensure Javascript is enabled for purposes of website accessibility Jump to content

My PODxt live is no longer regognized by my PC

Recommended Posts

My XT Live no longer is read by my PC...I tried everything, reinstalled drivers, reinstalled monkey, used several different usb cables (they worked fine with other hardware) I did not use my XT for months, but it worked fine the last time i tried nothing, no matter what I appears that my expasion packs no longer work either...please help

Link to comment
Share on other sites

Well expansion packs would be re-authorized through the L6 License Manager so no problem on that one.


So the usb connection would be the issue. 


If everything worked before it may be an issue with your PC. Try seeing if it connects to another PC (be sure not to use a usb hub).

Link to comment
Share on other sites

  • 2 weeks later...

I've referred to these articles whenever I've had an issue w/ mine:


You may have to uninstall all the software and start over.  Make sure that you follow the instructions as to powering of the Pod.


Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...