Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Problems with Pod HD Pro X


Recommended Posts



I'am sorry, but I am obliged to share my disappointment with Pod HD Pro X.

Primo - I can't use it as audio interface because there are always pops and clicks, what ever sample rate I use. No way to record properly. 

I have spent many hours with searching and trying, with no results !

I tried everything I have found on this web site and elsewhere, without improvement. So I am obliged to run it via an other audio interface.


Secondo - If I turn it up or down when my computer is on, it happens that my computer crushes, although it is a pretty powerful machine.

It is so annoying !!!


I am sure it is a last product from Line6 I have bought. 



Link to comment
Share on other sites

the problem with using the pod as an interface is likely a problem with other drivers on your machine, or perhaps even your usb port itself.

USB 3 ports can be finicky....

often times having a crazy powerful newer machine, means you have performance drivers that aren't very mature...

this affects the stability of the drivers....

also sometimes other USB devices can distract from the audio stream...

as well as power management or other operating system related settings.


make sure you also have the firmware of the POD updated to the latest as well.

Link to comment
Share on other sites

As I said, I've tried everything found on support forums, also with another computer - less powerful with USB 2 ports (nothing else connected, everything up to date).

No improvement. I value my time and if I pay 730€ for a product, I expect that it works as described in manual or your website.

There is no mention about these problems.

Anyway, yesterday I returned it to the store, they will send it for checking. If it does not improve, I will be obliged to sell it.

In that case I can't recommend your products to my students neither. Pity.



Link to comment
Share on other sites

USB 2 ports are not "less powerful" especially if you're plugging in a device that utilizes the USB 2 standard, the USB 3 standard allows for higher speeds etc... but only when using a USB 3 device... it ultimately should not matter because USB 3 should be backwards compatible... however, the newer standard has less mature drivers and does not always do backwards  compatible suitably for all devices.

I have the HD pro x myself, and your experience is not typical. I've used it on a few different machines both windows and mac without issue.

have you tried a different USB cable? (yes you say you tried everything on the forums... but no... i can't define what you call everything so i'm asking repetitive questions....)

that's one factor that would likely move between machines, taking the problem with it.

however unlikely, a genuine hardware issue is also possible, so replacement was also a good path forward. (a new unit would be a much quicker way to check...)

Line6 experts are not Line6 employees... so it's not it's not a matter of whether or not you recommend any products....

this is a user forum, and we're trying to be helpful... that is all... not trying to sell to your students.

the pod is worth the effort in the end, we're just trying to help you get there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...