Jump to content
Sign in to follow this  
dbedard67

DT25/HD500X issues when changing operating class

Recommended Posts

When I go from a Class A/B amp preset like a Blackface to a Class A preset like an AC30, I have two issues:

 

Dramatic Volume difference that I'm unable to control - I've tried adjusting presets to the same relative volume and saving, but I still have a huge volume jump going into Class A. Is this because of the topology and wattage change? Is there a solution?

 

Loud popping noise - same scenario. I don't get it when the presets have the same topology.

 

I'm wondering if I can use the DT25's two channels, one for each class, controlled by the HD500X? Would that avoid the issue?

 

I play Praise & Worship music, which is dominated by Fender & Vox tones, so I would like the flexability, but I can't have these issues in front of 1200 people on a Sunday morning..

 

Any experience with this? Do you know how to set it to resolve these?

 

Thanks,

 

Dennis >^..^<

Share this post


Link to post
Share on other sites

If I am understanding your post correctly, if you are expecting the volume to remain constant when changing the class on the same preset, that is not going to work...You can get a Class A and Class AB patch to be the same relative volume. If the amplifier is running fairly loud, there is a less of a pop when switching class like that between patches...The louder you run the amplifier, the closer the AB mode gets to running class a and you get less pop...Class A (Single Ended) and Class AB (push pull) are pretty different...and the voltage swings are pretty huge...try to stay in the same mode for performance if you are running the amp at a low level and changing patches...You can get away with it at higher volumes...but it sounds like you might have a quieter stage...An attenuator might be somethign to try...but switch classes is radical from the power amp operation standpoint. It takes a second or two for the amplifier to stablize when changing classes.

 

If you are really wanting to switch from a Fender to a Vox, why not run the AC30 patch with the actual correct class...An AC30 is actually a class AB amplifier...Lots of people think it is class A, but it isn't...It's an AB with a hot bias...just a thought...

Share this post


Link to post
Share on other sites

I meant changing between presets - I have Preset 1A with a Blackface Pre and Preset 1B with an AC30.

 

However - It's solved!

 

I only have that issue in HD500X Edit.  Once I disconnect the POD from the computer everything's running as I expected.

 

Thanks,

 

Dennis >^..^<

Share this post


Link to post
Share on other sites

I've found that when I use the HD500 with the DT50 without HD Edit or any connection to a computer I have a better experience with my sound. Don't get me wrong I love using HD Edit as it made it easier for me to learn the editing process and that's coming from someone who has never had a "pedalboard" in the past.

Share this post


Link to post
Share on other sites

Also, don't change between topologies or classes quickly.  Voltages change greatly and need to stabilize otherwise you will notice other odd artifacts.  Less noticeable in the 25, but 50 it becomes distracting. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×