Jump to content

POD 2.0 problem

Recommended Posts

My POD 2.0 just started doing a weird thing the other day.  I was playing around with it, as usual, then I left to get a drink, and when I came back the screen was repeatedly flashing "POD" then "2.0", and there was no output.  So, I turned it off, and then back on.  Same thing.  Turn it off and on again, and it doesn't come on at all.  Turn it off and on again, and the screen is extremely dim.  Turn it off and on again, and all characters light up "888", and still no sound.  Now, that's what I get anytime it is turned on.


It is using the correct power supply.


Any idea what is causing this, or how to fix it?

Link to comment
Share on other sites

  • 2 years later...

I haven't tried a different power supply yet, as I don't have one that does 9VAC.  I tested the original power supply with my multi meter, and it was reading 10.34VAC.  I'll see if I can source a new power supply before I scrap it.  Thanks for the suggestion.

Link to comment
Share on other sites

Tried a brand new power supply, but without any luck.  I'm pretty sure it's toast.  While I had it turned on, I started to smell something that smelled like my soldering iron when it's very hot.  Turns out the DSP chip (circled in the up close pic) was getting SUPER hot.  So, I highly doubt this is a fixable issue, or at least not worth fixing :(


Oh well, time to search for a new one I guess.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...