Jump to content

Screen freeze M20d


Recommended Posts

I have had my M20 for 11 months and haven't used it much as I have been saving for the speakers. On Friday I got a new xd v35 radio mic so connected up the desk and one L3m, all was well at first but then the screen started to get unresponsive. At first it was while I was trying to change reverb presets but then I tried to load a new scene and the screen totally stopped responding.

 

I tried switching on and off 3 times but to no avail. The audio output continued as normal.

Today I plugged in the desk and it has been fine. I have played back a couple of sets (provided by forum members) and made loads of changes/loaded new scenes etc and everything worked perfectly.

 

I'm just looking for advice as to whether Forum members think This might have just been a glitch or if I should get it checked out. I am conscious I only have a month left on the warranty.

Link to comment
Share on other sites

I would reinstall the firmware (it may even be an update after that long) and use the device daily for a couple of weeks if possible. If the problem reappears I would log a support ticket before the warranty expires.

 

http://line6.com/support/page/kb/_/live-sound/stagescape-m20d-mixer/stagescape-m20d-firmware-120-update-information-r555

Link to comment
Share on other sites

You are most definitely not alone. Check this thread, for example.

http://line6.com/support/topic/8962-m20d-screen-freezes-on-me-again/

 

I am waiting for my mixer to return from service.

All those voodoo suggestions ("use the device daily...") will amount to nothing but a waste of time, is my opinion. The problem WILL reappear (if it goes away in the first place). Get it serviced asap. Whether or not servicing will amount to anything is anybody's guess. At least one forumite reported success, so I'm keeping my fingers not only crossed but corkscrewed.

 

Six weeks later: M20d returned from service (the same unit that I sent), they gave it a "thorough check for several days" and failed to find a problem. Only that it took me all of 20 minutes to freeze the unit again. See original thread for details.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...