Jump to content
deadshred

Footswitch issue on DT-50 112 combo

Recommended Posts

hi there,

I recently bought a used DT-50 112 combo, and to make it easier to switch between channels picked up a Boss FS-5L foot switch. Tried it out when i got it a few weeks ago, worked fine. Hadn't put the amp on for about two weeks, then tried it tonight and had issues.

firstly when I put the TS cable into the foot switch input it would automatically switch from A to B, even when the foot switch itself was not connected. [never B to A though] I even had issues switching it back to A with the front selector switch.

 

 - I tried about six different TS cables, none of them worked with the foot switch.

 - Changed batteries in the Boss, [even though brand new], light would work to indicate it is working, but still no action on the amp. 

 

 

I then turned it off and back on again, holding down the channel select switch on the amp for six seconds. [read about it here somewhere, thought it couldn't hurt]. After this the foot switch input and the Boss would not change the channel, although the switch would.

 

Could the jack input be damaged in some way? and is it an easy fix?

 other than that the amp is fine, but its an annoyance to not be able to switch channels easily with the new foot switch. Has this happened to anyone else, and what was your solution?

 

Also, if needed, does anyone know the best place in Melbourne, Australia, to fix this type of issue?

cheers, Sean

Share this post


Link to post
Share on other sites

 

{UPDATE} it seems to be an issue with the inputs on the back of the unit. Curiosity got me, and i put the jack into the FX Return to see what would happen, it switched the channel from A to B. weird hey. it's like there's a short somewhere, cause I just tried it again and now it won't switch when i put it in the foot switch input, but it will when in the FX return one?  
 
I've tried a reset and reinstalling the firmware, still nothing. It also happens when i barely touch the back of the unit. i just knocked the cable against the back of the unit lightly and it switched channels!!? this is getting stranger by the minute!
 
Hey Line 6 peeps, are there any service centres in Oz? We've got a couple of Billy Hyde stores left, [they used to sell Line 6 gear, but not anymore], or should i just take it to any old music shop and see what they can do. I imagine things are a little trickier in the guts of the Dt50 as opposed to standard valve amps?

Share this post


Link to post
Share on other sites

Certainly is very wierd stuff. You sure haven't been watching the Stephen King Marathon lately? LOL. seriously hope you get it resolved though. Thanks for posting the symptoms.

Share this post


Link to post
Share on other sites

Why does your foot switch need batteries? It should be a strictly mechanical switch. Never heard of such a thing. Try a traditional 1 or 2 button foot switch.

 

hi there,

I recently bought a used DT-50 112 combo, and to make it easier to switch between channels picked up a Boss FS-5L foot switch. Tried it out when i got it a few weeks ago, worked fine. Hadn't put the amp on for about two weeks, then tried it tonight and had issues.

firstly when I put the TS cable into the foot switch input it would automatically switch from A to B, even when the foot switch itself was not connected. [never B to A though] I even had issues switching it back to A with the front selector switch.

 

- I tried about six different TS cables, none of them worked with the foot switch.

- Changed batteries in the Boss, [even though brand new], light would work to indicate it is working, but still no action on the amp.

 

 

I then turned it off and back on again, holding down the channel select switch on the amp for six seconds. [read about it here somewhere, thought it couldn't hurt]. After this the foot switch input and the Boss would not change the channel, although the switch would.

 

Could the jack input be damaged in some way? and is it an easy fix?

other than that the amp is fine, but its an annoyance to not be able to switch channels easily with the new foot switch. Has this happened to anyone else, and what was your solution?

 

Also, if needed, does anyone know the best place in Melbourne, Australia, to fix this type of issue?

cheers, Sean

Share this post


Link to post
Share on other sites

yeah i'll give that a go. The Boss runs on batteries for the LED I believe, but is a simple latching footswitch according the internet reports. It lights up when on/opposite when off. They're sold I assume under the pretense of being a simple footswitch. Weird thing is it worked when I first tried it.

 

http://www.roland.com/products/en/FS-5L/

 

 

Also, i just need to put a cable into the footswitch input for it to switch to channel B, [and it doesn't even need to go all the way in for it to make the switch]. Seems as soon as it makes contact with something inside it activates the switch to Channel B. 

 

will keep you updated if using a simple one way switch works.

Share this post


Link to post
Share on other sites

Ya, I looked it up after I posted.  One would assume it will work fine.  I hope you find a simple solution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×