These forums are read only, please use our new forums here.

Main :: POD 2.0, PODxt Family, Pocket POD, FloorPODs

Bass PODxt - Midi timeout
by lordoflow on 2009-07-14 22:33:18.0160

I'm having a problem running L6 edit on my computer. This seems to be a common problem, on the forums there are several unresolved posts related to this same thing.

I also own a guitar PODxt that works fine with edit. My best guess is that its a java conflict. Any suggestions? How about a new flash on L6 monkey for all the thousands of bass players out there.

Thank you for your time, I love Line 6 products.


Re: Bass PODxt - Midi timeout
by bcrichboy08 on 2009-07-15 10:36:00.4840

hey man yh its a common problem. as far as im aware line6 r lookin into it!

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-15 20:43:27.6210

I'm wondering how many months of "working on it" is required to get a solution?

Re: Bass PODxt - Midi timeout
by laplayantonio on 2009-07-16 02:01:01.5290


i'd recommend u to reflash your Bod XT: corrupted Tone downloads from the online library are often the cause for this Midi Timeout error on Bods, and the only fix is reinstalling the Flash Memory

please let me know if this works


Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-16 05:31:57.7530

I've re-flashed the memory too as well. Uninstalled and reinstalled edit, java, drivers and monkey. Tried older versions of them too. I haven't used any downloaded tones on my bass podxt. Funny thing is my red bean (guitar podxt) has worked with edit in all the combinations.

Re: Bass PODxt - Midi timeout
by laplayantonio on 2009-07-16 05:35:53.5520

did u select 'YES' when asked if you wanted to keep the user patches when reflashing?

'cause that way it won't work, you gotta get rid of the corrupted patch...

also, remember to try different USB ports (in case is a USB Midi interface) and update the Midi interface drivers, if possible...

hope this helps...

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-16 06:31:25.8270

I've done a factory memory recall. Cant reflash there is no option to do so on monkey. I've never used downloaded user tones on this unit. The same computer and usb cable/port (though I tried using the others justs in case) run edit fine on my guitar podxt.

Re: Bass PODxt - Midi timeout
by laplayantonio on 2009-07-16 06:39:40.2620

then I guess the USB chip in your unit is gone...

I'm afraid the only solution is repairing...


Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-16 06:48:22.6720

I think the usb jack is fine. I can run monkey just fine. L6 Edit recognizes until it loads patches. Then I get the error message.

Thanks for trying

Re: Bass PODxt - Midi timeout
by laplayantonio on 2009-07-16 06:53:19.8380

i meant USB chip (integrated circuit), not socket...

if my advice above on swapping PC's USB port doesn't apply, then I'm clueless...

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-16 07:33:20.5980

I'm thinking that usb is fine. I can record via usb to my recording software and it recognizes the Bpodxt (sounds awesome). As I stated before so does monkey. I just can't get edit to boot without this midi timeout error. I think I'm gonna try setting up on a different pc to see if that makes a difference. I'll post the results.

thanks to all who have tried to help, JD

Re: Bass PODxt - Midi timeout
by AParedes on 2009-07-16 10:39:26.5060


Yes, we have seen this situation a couple times but we have not been able to duplicate this here. Did you try multiple USB ports? Some USB ports may be more "robust" than others. See the following link for more USB connection information:

USB Connectivity with Line 6 Devices

Try a different computer as well to see if this changes anything.

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-16 13:59:04.1780

Thanks Andy,

  My computer has usb 2.0. I know that its working right. I can record with out a problem using usb. I've run all recommended tweak tip from L6. This is a copy of what the pc says is happening.

Stack trace: cmn.l6java.patch.L6PatchManager$DeviceNotConnectedException at cmn.l6java.patch.L6PatchManager.AcquireDevice( at cmn.l6java.patch.L6PatchManager.RequestDeviceEditBuffer_Sync( at cmn.l6java.patch.L6PatchManager.RequestEditBuffer( at line6editbase.editor.L6Editor.SetCurrentPatch( at line6editbase.editor.L6Editor.SetCurrentPatch( at line6editbase.editor.L6Editor.OnMIDIPatchChange( at cmn.l6java.patch.L6PatchManager.NotifyListenersOfPatchChange( at modules.sharctone.device.L6SharcTonePatchManager.OnPC( at cmn.l6java.midi.L6MIDIManager.OnPC( at cmn.l6java.midi.L6MIDIManager.HandleTrackedPC( at cmn.l6java.midi.L6MIDIManager.OnMIDIEvent( at cmn.l6java.midi.L6MIDIJava.L6MIDIJava.DispatchMIDIData( at cmn.l6java.midi.L6MIDIJava.L6MIDIJava.Run( at

I'm not sure what to make of this but maybe you can Andy. Does anyone know anything about l6 patch manager or java?

I haven't had a chance to try a different pc yet. The problem with that is I only have one recording pc so if it doesn't run on that one I'm SOL.

Thanks again for you time, JD

Re: Bass PODxt - Midi timeout
by AParedes on 2009-07-16 14:32:50.1250

Which version of Line 6 edit are you using? The final version of Edit included Java 5 update 11, which is required for running Line 6 edit (and will ignore later versions of Java). Please reinstall the latest version of Line 6 edit to see if this fixes the situation.

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-16 17:08:00.5760

Andy, I checked my java ver. and monkey did not install V 5.11 when reinstalling even though I was prompted during the install. I Had V5.14 loaded. I manually installed V5.11  uninstalled V5.14. Uninstalled edit and reinstalled. Same thing again midi timeout.

Curently installed on my pc.


Monkey 1.27

Edit 3.02

B. PODxt 1.04

java 5 update 11

Usb 2.0

Funny thing too is that there is no flash update or version listed on monkey.

Thanks, JD

Re: Bass PODxt - Midi timeout
by AParedes on 2009-07-17 10:24:55.6180

It still sounds like a communication error if you are not seeing Monkey look like this:


Please try a different computer with a different USB cable to see if you have the same results.

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-17 12:58:16.8780

Ok I Installed everything on a different pc, when I had the divers and monkey installed I had the firmware updates available and reinstalled them even though they where current. Downloaded edit w/ java update and fired it up when finished downloading. Runs perfect .

Now I figure that the firmware update may have done the trick. Hooked up the recording pc and MIDI TIMEOUT . I then went top to bottom of all L6 files and uninstalled and deleted everything I could find related to L6. There was some hidden stuff all over my pc. Got rid of all pod farm and riff works etc.

With a blank canvas I reinstalled in this order - monkey, drivers, then edit w/ java update and BINGO edit its running  . Now Monkey is still not showing usb or flash updates so I'm still not 100%. But, at least I can run edit.

Andy, A big thanks to you and all who tryed to help. This L6 community and support is the BEST.  JD


Andy, any idea why monkey is not showing my Device Firmware options? I'm not showing a dropdown menu for device firmware, usb firmware, or flash memory. Is this a vista issue? It shows on my other pc that is not for recording.

Re: Bass PODxt - Midi timeout
by laplayantonio on 2009-07-18 03:40:51.8130

well, that's what I advised you on the first place... (Flash Memory and Firmware are the same thing...)

remember to give points to the members that give correct answers...

Re: Bass PODxt - Midi timeout
by lordoflow on 2009-07-18 07:25:40.5990

Wasn't the flash. If you had read the previous post it didn't start working till I cleared  out all the old L6 files and not just uninstalling. I went through the whole pc and found a lot of things the uninstall programs didn't remove and manully removed them myself. It wasn't till then that edit would run. Me thinks the old versions of monkey, edit, drivers, riff works, pod farm, etc. were causing a conflict.  The flash was already current I just re flashed to make sure I was covering all the bases. After the re flash it still wasn't working on my recording pc.

The flash update still doesn't show on my recording pc when I run monkey. I'd still like to know whats up with that. If you can figure out why this is happening I will gladly award some points.

Thanks a lot, JD

Re: Bass PODxt - Midi timeout
by andykojezz on 2012-06-13 00:50:05.7940


I had the same problem. This is what helped:

1) Use LIne 6 Monkey to reinstall USB firmware and FLASH memory (this order).

2) Then use Line 6 uninstall utility to remove DRIVER and EDIT program.

3) Last step is factory reset of POD.

Restart computer and install DRIVER and EDIT program again without Java runtime (it worked for me).

IMPORTANT: Do not change any setting nor preset in POD before first succesfull connection with Edit program!!! Better do not even touch it.

It could be the reason of  midi timeout issue.

The information above may not be current, and you should direct questions to the current forum or review the manual.