These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort

UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by salinka on 2009-08-18 16:34:36.1140

I haven't checked the 'question' option before, and because of that no one from Line 6 probably saw this, so I'm posting it again, because it's very important.

It's quite a long and technical read, but it's important and I hope it will be forwarded to someone who is responsible for developing Line 6 Monkey

Configuration and hardware: Pod Studio UX2 (bought this week), newest software downloaded from the website (including Line 6 Monkey 1.30), Mac OS X 10.5.8 on a two year old MacBook.

Problem: installation of Pod Farm, including the drivers went well, the device works, Pod Farm works (sees the UX2 device) etc. but when I try to run Line 6 Monkey I'm presented with a message "No Devices Detected, please select the Line 6 device you'd like to configure:" and I'm able to select amongst only three devices: PODxt, PODxt Live and PODxt Pro.

I'm not the only one with this particular problem (see here , , or It's been going on for a couple of months)

Everything works fine on my other machines running Windows (XP and Vista), on the same network (no firewall).

Obrazek 1.png

But I didn't stop there and I think I found the solution to this problem, and I know why is it happening, and in order for it to work correctly every time you have to modify the software.

Cause: Let's break down how Line 6 Monkey works (at least that's what I think it does):

When you run it for the first time, it connects to the internet to download some kind of device definitions, which is a good thing because it should always stay up to date. If it does not detect an internet connection it uses a built-in database of device definitions (they are integrated in the software, on a Mac inside the Line 6 So far so good. But if Line 6 at least once connected to the internet and downloaded the definitions, then it never uses the built in database, even when there's no connection, instead it uses previously downloaded database located in Library/Application Support/Line 6/default.cfg.

And that's where the problem appears, when the Mac version of the software connects to the internet for the first time it download a bad database (very old one, only with three devices mentioned earlier, it's located here: ) therefore from now on, even with the internet connection down, it uses this bad database and doesn't work with other devices.I've verified it by copying the good database from inside the app to Library/Application Support/Line 6/default.cfg and shut down my connection (in order to force the app to use the good database). Then it all worked on my mac, my device was recognized and could be authorized. But when I tried to run with internet connection on it downloaded the bad database and from that point on it refused to work again. So it cannot be fixed without changing the way this software works.

I've also noticed that other people who have this problem (from the links I've provided) attached their log files. In everyone of them (including mine) there was this line:

     Redirecting to: (this is the old database)

Which makes me almost certain that this is the issue.

Solution: There has to be a problem with the way mac version downloads the database. I think I found why:

The URL it tries to connect to in the mac version is as follows:

But in windows version it is: So maybe it should be changed somewhere inside the app

Probably it's a very easy thing to fix, and I wonder why it hasn't been fixed so far. Because of this error I cannot authorize my device on this computer, and use every feature I've paid for.

That's my theory, I hope it will allow you to improve your otherwise great software and hardware.

Kind regards,

John Skommer,

P.S. sorry for my english, I'm from Poland

Here is my log file (I highlighted what I think is important):


- Monkey started: Tue Aug 18 16:00:05 2009



Mac OS 10.5.8

Downloading config file:

Redirecting to:

Loading server XML

Monkey URL set to:

Camel server set to:

Creating Camel system with timeout of: 60

Initializing camel: camel://

Getting driver versions...

Found: 291 bundles

Found matching L6Driver: com.line6.driver.xtaudio

Found version string: 4.2.4

Driver added: 0x00006E03

Couldn't find a device descriptor...thats ok, creating one.

Created device description: VID=0x0E41 PID=0x4151 Name=UX2 UID=Line 6 UX2: 01714365 DriverVer=4.2.4

Fired CONNECTED dev change notification for: UX2

Previous app device found: connection=0 in= out= id=4294967295

Created Monkey device: UX2

Device not supported.

Scanning for all MIDI devices.

Sending MIDI inquiry on output port: UX2

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by ricksox on 2009-08-20 10:12:12.7720


I noticed that you reside in Poland? Just out of curiosity, can you check the date and time on your computer? Try changing it to US time instead of your local time and reconnect. Let me know if that makes any difference at all. Thanks.


Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by salinka on 2009-08-20 10:34:43.6980

Thanks for your answer.

Unfortunately It didn't help. I've tried changing my time to every single timezone that is in the US (the date is correct). I don't think that's the case because my other computers (running Windows) are also in my timezone (Poland) and they work without a problem.

I've also tried a couple different things. I had access to an other mac, a newly released MacBook Pro (also 10.5.8), and the problem remained, so it's not my computer fault per se. I have also tried to eliminate the network factor, I've tried over WiFi, ethernet, and even on entirely different internet connection, direct, without a router (or firewall). Didn't work. I'm pretty certain that it has to do something with the way it connect to your servers on Mac's, what I can't understand is why it works for some people, and for others it doesn't.

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by ricksox on 2009-08-21 11:41:47.8730


Thanks for all of the detailed information. I just scoured our bug database and it looks like we have a bug logged for this and are actively pursuing the root cause and fix.

I'm going to add your information to the bug. I created a support ticket for you requesting some further info. Please see the ticket!!! Thanks!!!

Q: What is a support ticket?

A: A support ticket allows you to directly correspond with a Line 6 Support Representative. An email will be sent to you from Line 6 containing a link if a Line 6 support representative determines that a ticket is necessary to troubleshoot your issue. Please follow the link in the email to view your open ticket to work one on one with Line 6 Support.

Please note: Sometimes support tickets will be filtered to spam and junk folders. If you did not receive an email from us indicating that a ticket has been created, please make sure to check those folders in your email host.


Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by salinka on 2009-08-21 14:30:29.8700

Thanks for all your help. I've filled out my support profile and provided everything you asked for. So I guess that I have to wait now I hope that my posts will help you find and correct this annoying bug.

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by mikhael91 on 2009-12-08 13:04:24.5360

hello, i've got excatly the same problem, funny thing, im also from poland. i read about this ticket thing, but unfortunately, i wasn't able to find the way to use it, so im writing here, hope You guys don't mind. i would highly appreciate any help in this matter, because this problem not only unables downloading updates, but also cause logic pro not to use pod farm properly. what i mean by that, is when i wanted to use pod farm as a 'stombox' in logic interface, line 6 monkey  immediately showed up, and obviously in this situation blocked everything.

kind regards, Michał Rassek.

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by Misha_S on 2010-01-18 12:57:05.7490

Hello! I have the same problem. Have you found any solution? Thank you.

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by jackalfeud on 2012-03-16 09:27:57.1700

I have the same problem from northren ireland only I can only select POD xt - pod farm won't detect the device either. Guitarist accidentally registered the device and some of the software to his windows machine - could this be possible cause? Shot in the dark. This is highly annoying (goes without saying).

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by mathisscott on 2012-05-24 19:39:59.8360

I'm having this same problem and I'm in Austin, Texas -- United States.

Re: UX2 not recognized by Line 6 Monkey in Mac OS X 10.5.x [possible cause found]
by guitarguy349 on 2012-09-06 07:15:55.0660


I have a smilar problem

Id be grateful if anyone has the time to help solve my situation

I just recieved the UX2 this week, I installed pod farm, set up all the ports, plugged the USB port from the UX2 to the mac, guitar lead plugged etc. everything went smoothly. Then I noticed I coudn't hear the output signal of my guitar I check the sound through Sound Preferences, and it picks up signal. I restarted my Pod Farm 2.1 and it came up with a message stating that I needed to install the latest version of Line 6 Monkey to access the signal through the UX2 and Pod Farm. I tried to install it but every time I try to download the update I get the same message stating 'Line 6 Monkey cannot be installed on this computer'. So im left with nothing. Help?

The information above may not be current, and you should direct questions to the current forum or review the manual.