These forums are read only, please use our new forums here.

Main :: POD X3

Can't install pod x3 live usb drivers
by horkid on 2010-01-08 09:11:01.4600

Tried with both desktop (amd athlon 64 x2 4400+, 2 gb ram) and laptop (asus x55s), with both windows 7 and windows xp sp3. Under windows 7 tried driver pack, under windows xp tried driver pack, 1.31 monkey, 3.70 gearbox and 1.11 pod farm. While installing drivers under winxp windows with question about installing untested software are closed automaticaly, visibly selected choice is don't install, though i don't know which one is selected for real. After installing drivers with monkey, monkey don't recognize drivers as installed ones. Under win 7 driver pack asks for permission to instal drivers. I choosed install option. But after connectiong device  and trying to find drivers for it it's still impossible in both systems on both computers.

Re: Can't install pod x3 live usb drivers
by Line6Hugo on 2010-01-12 11:03:15.1650


In Windows XP, when you get a Windows Logo Testing pop up during the driver installation to your USB port, you need to select continue anyway to complete the install.

Please make sure to disconnect all other USB devices (except for a mouse and keyboard) while troubleshooting this issue. Disconnect ANY USB hubs, even if not in use and test the hardware on every USB port.

Windows 7 is not currently supported at this time, so any problems with using the beta drivers should be reported at the Windows 7 beta users group:



Re: Can't install pod x3 live usb drivers
by horkid on 2010-01-13 06:15:31.2790

Pop up windows weren't the source of the issue. Using dpinst i manually installed .inf. And even so windows won't recognize device. All usb hubs but rear root and front root hubs are diconnected. All usb devices but mouse are disconnected.

RE: Can't install pod x3 live usb drivers
by AParedes on 2010-01-13 10:27:04.5680


We will assist you with your XP install, as Windows 7 is not supported. Please go the following link to download/install the Gearbox 3.70 software installer for your XP Operating System, which also includes the Line 6 monkey intelligent updater and the latest drivers for your Line 6 POD X3:

Copy/paste the following links (beginning with http) into your internet browser for additional Line 6 software information:

Line 6 Monkey Installation and F.A.Q.

Windows: USB Device Driver Installation

Video Tutorial: Installing Line 6 Drivers & Monkey to a Windows XP System

Use the information in this link to optimize your computer to work with Line 6 Gear:

Computer System Audio Optimization

See your manual for more application information:

Gearbox Program manual

See the following information for setting up your Line 6 device as the soundcard on your computer:

Setting up your Line 6 device as External Sound Card within Windows XP: Video Tutorial

Assigning your Line 6 Device as a Sound Card on your Windows XP Computer: Screen Shot Tutorial

If you need further assistance, please provide the following information:

• Line 6 Product: X3

• Flash memory, USB Firmware versions installed:

• Line 6 Monkey version installed:

• Line 6 Drivers version installed:

• Line 6 Application (i.e. Riffworks, Line 6 edit, Gearbox) software and version:

• Operating System version

• Is this a dual boot system? If yes, please list all applicable operating systems:

• CPU / Processor Type and Speed

• Amount of RAM

• USB Ports: (#, location, speed 1.0/2.0):

• USB Devices connected to on your system: (Including any HUBs):

• Security software installed on your system (anti-virus, pop-up blockers, firewalls):

• Audio recording programs on your system (i.e. Sonoma, Ableton, Cakewalk, Pro Tools, etc):

• Audio playback programs on your system (i.e. Real Player, Winamp, Itunes, WMP):

• Type of internet connection: Cable modem, DSL, satellite, dial up:

Please note: Line 6 does not support satellite or dial up internet service

General troubleshooting questions (choose N/A if it does not apply):

• Does Line 6 Monkey recognize your device?

• Have you reinstalled the drivers for this device directly from the Line 6 website for your OS?

• Have you tried different USB cables?

• Are you connecting directly to a USB port on the back of your computer?

• Have you shut down all security software/other programs?

• Have you tried to replicate the problem on a different computer?

Re: RE: Can't install pod x3 live usb drivers
by horkid on 2010-01-14 03:09:05.8040

1) POD X3 Live

2) I don't know version of flash and firmware because i was't able to connect device

3) Monkey 1.31

4) drivers

5) For now only monkey and drivers, though i tried gearbox and podfarm

6) Windows XP SP3

7) Yes, dual boot, other system is windows 7

8) Amd Athlon 64 x2 4400+

9) 2gb ram

10) four rear usb 2.0 ports, four front usb 2.0 ports

11) only a4tech x6-60d mouse

12) no security software

13) no additional recording programs

14) no additional playback programs

15) dsl connection

16) Monkey don't recognize neither device, nor installed drivers

17) Yes, drivers are downloaded from the site.

18) No, i'll try that, though i don't think that this is connection issue, windows sees the device, though it can't recognize it.

20) I tried all of rear ports and 2 front ports

21) There is no security software on my win xp

22) I tried it on my asus x55s laptop. Same problem here. But it has same dual boot system, also has nvidia motherboard chipset and realtek audio chipset.

As for links you provided. The situation while installing drivers is slightly different. After conecting device when driver's installer says to do so it is recognized just as usb device, not like pod or some specific device. Until that installation went as it should.

Re: RE: Can't install pod x3 live usb drivers
by freebluehat on 2010-04-02 06:18:39.9770

same thing here... but i get one of the usb device is malfunctioned.. i think my x3 is broke

Re: RE: Can't install pod x3 live usb drivers
by leeeden on 2010-09-26 01:29:08.1250

did u ever sort this out... i am having a similar issue with mine. i have checked my x3 to see what usb firmware is on it... it says 0.00. if you hold down the outputs button and scroll down you can check that. I am getting ready to send mine back. obivously a lemon.

Re: Can't install pod x3 live usb drivers
by horkid on 2011-01-26 05:37:52.7800

Problem still haven't been solved. My usb firmware versin is 0.00 too. Is there any way to solve problem beside sending device to service center?

Re: Can't install pod x3 live usb drivers
by san-3m on 2011-03-12 06:14:09.3430

Remove all USB controllers from your system, hives in regystry and begin installation again. Google how to remove usb controllers from system.

Here it's in Russian:

Удаление VID_.... ключей из реестра приведет к распознаванию USB устройств заново при рестарте системы.

ПРЕДУПРЕЖДЕНИЕ: Если у Вас USB мышь или клавиатура, не удаляйте их ветки реестра, иначе Windows при рестарте может глюкануть.

Определить эти ветки можно кликнув на "+"  VID_.... ключа и кликнуть на ключ ступенькой ниже. Если справа в значении переменной DeviceDesc Вы увидите что-то типа "Human Interface Device" или HID - то это как раз мышь или клавиатура.

1. Кликните Start. Кликните Run. Напечатайте regedit и нажмите OK.

Должен открыться редактор реестра.

2. Перейдите на HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB.

3. Выделите и удалите все (кроме HID) VID_.... ключи.
Не получается?! Правильно! Сначала должены быть установлены права доступа на соответствующий ключ VID_.... реестра. Для этого:

правым кликом на соответствующем ключе открываем меню и выбираем Permissions.

выбираем Everyone (Все) и назначаем Full Control (полный доступ).

Кликаем Применить, затем ОК.

Re: Can't install pod x3 live usb drivers
by horkid on 2011-03-12 08:40:16.9880

well, i tried this stuff. It could be helpful if the problem was in the pc. But the problem is in usb contorller of the pod x3. I tried device with 4 or 5 deifferent pc's at this point, with different operating systems (though all of them are from windows family), with 3 or 4 different versions of drivers, and still problem isn't solved.

What could solve the problem is changing controller or maybe changing it's firmware which version is 0.00.

А теперь по-русски.

Я попровал этот способ. Он бы мог помочь, будь проблема в моем компьютере или способе подключения. Но проблема в usb контроллере pod x3. Я пробовал 4 или 5 различных компьютеров с разными операционными системами, 3 или 4 версии драйверов и проблема все-равно не была решена.

Что могло бы решить проблему так это замена usb контроллера pod'a или его перепрошивка, версия которой сейчас 0.00 (что на мой взгляд указывает на проблему).

The information above may not be current, and you should direct questions to the current forum or review the manual.