These forums are read only, please use our new forums here.

Main :: Vyzex Editor

Pocket POD (Vyzex Software probably) problem
by Miszab on 2010-08-01 15:26:09.4230

I`ve bought Pocket POD about half year ago.  I`ve installed Vyzex, connected PP, and I`ve started playing guitar w/o any problems. Until yesterday.

When I loaded Vyzex as usual it was an alert that MIDI ports are not opened. I`ve checked all out (with some other MIDI devices and their software, Bass POD XT a.t. ), and it was all OK.

Sp, I`ve made some changes in Windows registry (as it is shown in Troubleshooting Vyzex manual). Any changes.

What is the problem?

When I start Vyzex - the software loads any set automatically (such option is checked in preferences), as so far. I loaded it manually and synchronized with Pocked POD . All seems to be OK then, but it isn`t.

I can fully use (with editing, etc) only the very first of bank tones. The rest of them I can load by clicking on the name, but ... in the Pocket POD memory is loaded not the clicked tone, but its predecessor. Strange. And without possibility of tone editing. It plays with first tone parameters. Choosen predecessor name is on the Pocket POD display, but on the Vyzex editor its still the first bank tone name and parameters. Very strange. Thats not all. If I load a single tone (saved earlier) from disk - all is OK. Vyzex changes a name and parameters, Pocket POD too.

I`ve tried USB port change (my PC has 6 USB slots, and there is still the same "effect" in each of them).

I`ve change the USB cable. Nothing...

I`ve uninstalled Vyzex and installed it again. Any change.

I`ve checked my disk with Panda antivirus software. Any viruses, any trojans.

I have Windows XP Home with SP 3 installed, and I`ve used Pocked POD aprox. a hour each day from January 2010. I`ve installed any new software in last three months

What can I do?

Excuse for my English

Re: Pocket POD (Vyzex Software probably) problem
by Miszab on 2010-08-05 12:16:26.7260

I solve the problem myself. The reason is a Chinese man who assembled my Pocket Pod for Line 6.

An AC socket was so poorly mounted, that after approx. only 200 times (once a day) putting the DC1 plug in and out it breaks down and caused vwrry short ans undetectable power pauses. After such pause Pocket Pod goes mad.

I`ve soldered a new socket and all is OK.

(i know that my guarantee is invalid now, but I have not time to wait 4 weeks for such small repair, and I don`t want to waste money for sending Pocket Pod to repair shop (such strange guarantee conditions I`ve got from a dealer)

Re: Pocket POD (Vyzex Software probably) problem
by PsicraftTony on 2010-08-05 21:16:10.8250

Hi Miszab,

Glad to see you are resourceful enough to fix this hardware problem in your PocketPOD.

Anyone reading this thread should note that Miszab used the editor software without issues for a year and a half, but when he had a problem connecting his PocketPOD one day, his conclusion (as posted in the topic title) was that it was probably the Vyzex editor software's fault.

We see this a lot on the forum and we are used to it by now, but it's very important to note that if Vyzex can't connect to your instrument, this is because of one of the following issues:

  1. A hardware problem in PocketPOD - broken USB port or power plug
  2. A hardware problem in your USB cable - poor quality cable
  3. A hardware problem in your computer's USB port - usually because it is shared internally by your PC or Mac
  4. A Windows OS problem involving the single-client MIDI USB driver being 'taken' by another program
  5. A Windows OS problem involving another device's single-client USB driver being unable for opening by Vyzex when it launches
  6. A Windows OS problem involving another USB device like a webcam or mouse interfering with the USB MIDI driver supplied with Windows that PocketPOD uses
  7. A probem with your Vyzex installation - missing or deleted files or preferences.

While number 7 in this list is the least likely to be the case, it is often the first thing a frustrated user assumes, which is fair enough and completely understandable. Hopefully this topic will shed some light on the situation for anyone else in this situation. If not, we are always here to help those who can't help themselves like Miszab did!



Re: Pocket POD (Vyzex Software probably) problem
by Bolt_t on 2011-04-02 03:30:23.6770


i bought a pocket pod a few days ago, and i spent hours and hours trying to figure whats wrong with the vyzex program.

Whenever i launch it i get this error message error.jpg

The midi in is working fine. But the midi out seems to be used by something else and i can't figure out what it is. I followed the Vyzex troubleshooting pdf instructions (the ghosted devices and the logitech drivers thing), but still nothing.
I'm suspecting my logictech webcam to be using it, but i uninstalled the device, and it still didn't work. I also use a logitech keyboard and mouse, which i also unplugged to see if it would work, but no it didn't.

I tried the software/pod on another computer and it worked just fine.

I'm using win7 64b, and the second computer i tried it on runs on vista 64b.

Any ideas ?

Re: Pocket POD (Vyzex Software probably) problem
by PsicraftTony on 2011-04-02 03:53:02.7190

Hi Bolt,

There is nothing wrong with the Vyzex editor for Pocket POD: The error dialog you posted is trying to tell you that another program is using your PocketPOD's USB MIDI port. That's because the Windows MIDI driver is single-client, only one program can access it at a time - Whichever program gets the MIDI port first blocks all others from using the MIDI port until it closes.

If you have any DAW software running you are going to have to deselect the PocketPOD USB port for use in it whenever you want to run the Vyzex editor, or conversely you can close the other program, run the editor to set up and sync your sounds to PocketPOD, and then close the editor and relaunch the DAW.

It's puzzling that Windows 7 has the same USB MIDI port limitations as Windows ME (the 1998 version of Windows that first supported USB)... 13 years is a long time for Microsoft to ignore a key feature like that in my view. Still, PocketPOD and all other 'no drivers required' USB MIDI devices are stuck in an environment where only one program can access them at a time...for Windows users at least - Mac OSX does not have this problem.



Re: Pocket POD (Vyzex Software probably) problem
by Bolt_t on 2011-04-02 03:59:46.6540

thanks for your answer. I closed all suspicious programs/services, and it still gave the same error. How do i know which program is using the midi port ?

Edit : i had FL studio installed but i deleted it  this morning. Could it have left some 3rd parti plugins or programs that would still be there and using the midi port ?

The information above may not be current, and you should direct questions to the current forum or review the manual.