These forums are read only, please use our new forums here.

Main :: M5 / M9 / M13

Problem with M9 Looper
by stevoj on 2010-09-29 12:32:55.4050

I sometimes get a really nasty, almost ring-modulated type of distortion when using the looper.  It tends to happen under the following circumstances;

1.  when recording a long loop, and

2.  when using 'reverse' and/or 'half speed', especially after switching back and forth between these modes.

The distortion usually seems to affect recently recorded overdubs - ie, the first few loops remain unaffected.  This can occur even when using no effects at all.  It can range from mild to extremely severe distortion (virtually unrecognisable sound).

My set up is pretty simple;

guitar ---> M9 (ver 2.01) ---> amp (or mixer, stereo).

Have I got a dodgy unit, or is this a known issue ?  Any help much appreciated,


Re: Problem with M9 Looper
by stevoj on 2010-09-30 05:31:46.0390

I've also just noticed that problem is most likely to occur if the overdub button is kept permanently on.

RE: Problem with M9 Looper
by darealagentp on 2010-10-01 14:28:20.7580


Any possibility of connecting your M9 via MIDI-to-USB interface to a host computer running Line 6 Monkey software to re-install the Flash Memory component?

What happens after you do this?

Also, were you using a specific effect or set of effects in tandem with the loop? Is the loop set "Post FX" or "Pre"?



Re: RE: Problem with M9 Looper
by stevoj on 2010-10-02 04:39:55.7820


Many thanks, re-installing the f/w seems to have solved the problem (I've been giving it rigorous testing this morning, and it now seems to be distortion free).

In answer to your questions, the problem occurred even when all the effects were off, and setting pre- or post-FX made no difference.

Do you know why this happened, and is it likely to recur?


Re: RE: Problem with M9 Looper
by stevoj on 2010-10-03 09:00:26.6770

Oh-Oh, I spoke too soon, just using the looper again today, and I have the same problem, although it occurred only once.  This time, however, using a very short loop (approx. 4 secs), only FX is some very mild compression (Vetta Comp).  Unusually, this time the problem appeared after a short period of use - only a couple of overdubs, using 1/2 speed, and pressing the Rev button twice.

Erasing the loop and starting again, I couldn't reproduce this fault.

I had wondered previously whether this issue was an odd manifestation of distortion of the OP stage due to having too many layers (ie, too much volume), but today's occurrence pretty much rules that one out (as I said, only 2 or 3 low volume overdubs made at the time).

Getting pretty fed up with this

Any ideas?



Re: RE: Problem with M9 Looper
by stevoj on 2010-10-16 06:19:45.5580

Hi again,

Here are 2 short loops to illustrate this ongoing problem, and I'll try to explain exactly which buttons were pressed.

Pt 1 was recorded with no FX.  A single chord is strummed once and the REC button is pressed while the chord is decaying, and a short loop is made by pressing the REC/ODUB button again.  I start adding some more notes, and immediately press the REV button.  Everything I play from this point comes out really distorted (listen 00:08 until 00:35). REV is pressed once more, and everything overdubbed after this point seems to replay OK.

Pt 2 was recorded with only a small amount of mild compression.  I tried to reproduce the button presses, and although timing points are different, the same problem does recur (distortion occurring in the recorded data after pressing REV while still in OVERDUB. Then, after pressing REV again, new layers are recorded normally).  At the end of this track, I also pressed HALF SPEED so you can hear the distortion differently.

Looper set to POST on both pieces.

btw, this fault is intermittent, ie, I can only occasionally reproduce it.

I hope this demonstrates the problem adequately.

Please let me know if this is a software bug, or whether I have a faulty unit.


Re: Problem with M9 Looper
by bmonroney on 2013-03-28 09:16:47.6580

I've just reported this bug again to Support and referenced this thread. Very frustrating for those of us who use the looper extensively (or would like to ...). I'm curious if the same issue occurs in the M13 looper? I would think that part of the firmware must be the same code?


Re: Problem with M9 Looper
by phil_m on 2013-03-28 10:43:39.8870

It doesn't happen on the M13.

Re: Problem with M9 Looper
by bmonroney on 2013-03-28 17:23:27.9880

I got a response from support:

Mar 28, 16:52 PM

Hello,  Now I do remember that issue and yes it is a bug within the looper of the M9. 

There is no word on when this will be fixed or where there will be another firmware update for the M9.

The last update for that was January 2011. 

Regards,  Line6Hugo

So there you have it. Known bug, no intention of fixing it, even though the M9 is still in production and widely available. This is disappointing - I am accustomed to companies like Metric Halo who believe in future-proofing their gear with continual software and hardware improvements. How many man-hours would it cost Line6 to track this down and fix it?


The information above may not be current, and you should direct questions to the current forum or review the manual.