These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort

Toneport UX2 models no longer work
by dirckb on 2011-01-08 16:48:09.0530

I have Windows 7 64, and a UX2 with the full complement of model packs.  The line 6 stuff was working, but I had to replace the motherboard, and now

none of the model packs work.

* Uninstalled & Reinstalled, Drivers, Pod Farm 2.02, Monkey 1.34 and Gearbox 3.72

* No error from Pod Farm, but Gearbox says:

     DSP failed to load model correctly.  You may not hear the selected model.

     Reason: (Code 80007104) Failed write to firmware.

Other stuff I've tried:

* Authorize "refresh" from monkey

* using a different USB port on the computer

* using a different USB cable

* transferring the model pack off and onto the device again

* moving the ".aet" file from a computer that works (Windows XP machine with no problems)

The motherboard that worked was a Gigabyte P55-USB3

The new motherboard that doesn't work is an MSI P55-GD80

Not having the model packs is a serious drag.

Re: Toneport UX2 models no longer work
by dirckb on 2011-01-14 20:34:06.6230

Really, guys?  No answer from Line 6 at all on this question?

Workaround:  I added a PCI to USB 2 card from Rosewill, NEC chipset, part RC-101,

and boom: it magically works.  Looks like the Line 6 drivers don't like the USB chipset on the MSI motherboard.

The usbview program shows two of these for the old ports:

Intel(R) 5 Series/2400 Chipset Family USB Enhanced Host Controller

each one has a RootHub and a Generic USB Hub below it, built-in on the motherboard.

The new NEC controllers only have a root hub, no Generic USB Hub built in.

At least I've got it working.

RE: Toneport UX2 models no longer work
by ricksox on 2011-01-17 16:53:06.8500

Sorry for the delayed response here. We are pretty backed up here in support and are doing our best to answer questions as fast as possible.

Thanks for following up on what your workaround is. If Line 6 Monkey was detecting your device when connected to your motherboard via USB, then is certainly should have seen your packs, especially after a refresh.

Not sure why that didn't work but I'm glad you're up and running.


Re: Toneport UX2 models no longer work
by dirckb on 2011-01-17 20:09:18.5380

Thanks for the reply.  I know it's easy to get backed up in support.

Everything worked fine except for the model packs.  It seems like using them on a new machine (or a new motherboard) requires writing something back to the device during authorization/activation, and the USB write-to-device code must not be 100% correct.  I'm going to leave this question open since it seems like a fairly common complaint.  If you ever get a version you want me to test, I can pull the USB card out and try the motherboard ports again - although now that the packs are working, it may not need to write to the device again - I can verify that one way or the other before installing the new code.

Re: Toneport UX2 models no longer work
by dirckb on 2011-01-25 12:17:28.1720

*bump* to keep this ticket open - line 6 has not addressed the problem

RE: Toneport UX2 models no longer work
by ricksox on 2011-01-25 15:15:43.3610

I honestly do not think there is another solution for your issue other then the PCI card you installed.

There are so many possible variables from computer to computer that the same symptom may be resolved through different means from one machine to the next.


Re: RE: Toneport UX2 models no longer work
by dirckb on 2011-01-25 15:35:07.0530

I don't need another solution; Line 6 does.

Apparently the software doesn't work with some USB chipsets.
This is something that ought to be on development's bug list.

As a software engineer, I know that there's always a backlog of
work, both bugs and features, and setting priority is difficult.

Since this seems like a common complaint, I wanted to leave
this open and volunteer to help test if the engineers come back
with a potential fix.

If you guys really don't give a shit, go ahead and close the ticket.
At this point, it's no skin off my banana.

RE: Toneport UX2 models no longer work
by ricksox on 2011-01-25 15:45:26.7090

Thanks for your feedback. Please be sure to submit it below as well:

I will also log your inquiry as a quality concern.


Re: Toneport UX2 models no longer work
by davpat on 2011-09-05 11:10:16.6490

I have exactly the same problem. I bought new laptop ESPECIALLY to work with my UX2 and everything is like dirckb said.

Gearbox don't work. POD farm do, but i can't practise with lessons in GPO...

Did you find solution?

Re: Toneport UX2 models no longer work
by greghutch on 2011-09-07 18:07:58.4020

GuitarPort UX2 & Windows 7 32 bit don't play well together. I have installed all latest drivers and still opening GuitarPort puts CPU so high PC is almost locked up. Stop the process and CPU is fine. Start GuitarPort again and CPU goes to roof. I see this has been an issue for a couple years now but I do not find where it has been addressed. I have seen many users doing their best to find a good work around but I think Line6 should fix their driver.

The information above may not be current, and you should direct questions to the current forum or review the manual.