These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort

UX2 not detected by software; run a legacy CPL elevated?
by innerfears on 2011-07-01 00:09:40.8740

I have what I believe to be a rather unique problem with my POD Studio UX2. I'm running Windows 7 32bit and it shows up in Device Manager, Sound Properties, etc. with the current driver. All of a sudden recently it's stopped being detected ONLY by Line 6 software, so I can't use it for recording and the level meters do not show any activity when plugging my guitar in. The last thing I was doing before I got this problem was running Fruity Loops Studio 9.

It's worked fine for over a year, I've had it installed to the same  computer, never any others... USB ports and cables all tested and  working correctly, the UX2 comes on and I can play audio from my  computer when plugging my new speakers up to it. I first noticed the problem just today when I tried to load up POD Farm 2 and it got me to update Line 6 Monkey, so I updated to v1.41. I also updated POD Farm 2 to the latest, but I started having this problem beforehand.

When loading Line 6 Monkey it says No Devices Detected and prompts me to choose from a dropdown list of devices to configure. I've tried this 3 separate times now, and every time it takes me through the usual process of unplugging the UX2 from my computer, installing drivers and whatever else. It completes successfully and the popup window at the taskbar says "device installed successfully" when I plug in. When I'm able to actually load Monkey, it falsely tells me Line 6 drivers aren't installed when I know they are because it's recognized by my computer every time.

I've tried this process twice now and another time by manually downloading the drivers and all software from the Line 6 website. I uninstalled everything, reinstalled manually and it's giving me the exact same message everytime - no device detected, but showing up fine in Windows. POD Farm 2.5 just tells me that my device isn't authorized and runs in trial mode... so when I load the Line 6 License program, it shows my computer as authorized! This doesn't make any sense!

I also noticed when I try to load Hardware and Driver Settings from POD Farm, a Windows dialog pops up asking for permission to "Run a legacy CPL elevated". This happens regardless of running as Administrator or not.

I suspect some sort of ASIO4ALL problem, which would make sense since FL Studio uses ASIO4ALL but I don't know what to do. "Line 6 UX2" is activated in it.

I've had issues with getting my UX2 to be recognized in the past, but it was like a walk in the park compared to this problem - any solution I've found doesn't seem to work. Please help!

RE: UX2 not detected by software; run a legacy CPL elevated?
by Line6Don on 2011-07-01 16:00:06.0550

Hey innerfears,

I would reccomend to completely uninstall the ASIO4ALL driver, and then If you are still experiencing this problem, please try using the Line 6 Uninstaller located at:

C:\Program Files\Line6\Tools

Launch Line 6 Uninstaller and uninstall all of the of your current Line 6 components.

Download the most recent version of the Drivers and Line 6 Monkey from our software page:

Install the drivers, and after it completes successfully, launch Line 6 Monkey to verify it installed correctly as well as download and update any other necessary components.

If you after removing ASIO4ALL and reinstall latest Line 6 software, the problem is gone, then the problem was with conflicting drivers on your system.

Re: RE: UX2 not detected by software; run a legacy CPL elevated?
by innerfears on 2011-07-01 16:27:25.4740

Just tried it and it's still not being detected... followed the instructions word for word, uninstalled EVERYTHING (ASIO4ALL, all Line 6 software) and reinstalled just the drivers and Line 6 Monkey, and it's still showing up in Device Manager with the current drivers but Line 6 Monkey is still telling me the drivers aren't installed. I've never had this bad of a problem with hardware before and I am absolutely stumped as to what to do.

The information above may not be current, and you should direct questions to the current forum or review the manual.