These forums are read only, please use our new forums here.

Main :: James Tyler Variax Guitars

Support community for JTV.

JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-25 06:37:40.9560

This problem occurred once and I resolved it by reflashing the JTV-59 to reload the V1.7 firmware.

I am raising this discussion to document the issue and ask Line6 if they can ensure that a firmware fix is written to resolve it so it doesn't bite anyone else.

Scenario - JTV-59 on v1.7 firmware connected to X3L via VDI.   Programming patches on the X3L to save the JTV model secltion with the patch.  The X3L was connected to my Marshall EL84 20/20 poweramp.  As I was programming patches I suddenly became aware of a very annoying buzzing soundcoming through the speaker.  I didn't know if this was caused by the JTV or the X3L.  So I decided to disconnect the VDI from the JTV and reconnect it to see if maybe I had not seated it properly.  However, this did not fix the buzzing.  BUT - I noticed that I could no longer select or store the JTV model selection with my X3L patch.  Each patch input started with DONT FORCE MODEL but when I used the knob on the X3L to select Variax/JTV control, the display changed to V1.70 MODEL.  It then would not go back to DONT FORCE MODEL and would not allow any model selection either via the knob or via the controls on the JTV.  This persisted even after powering off the X3L and powering it back on and after resetting the JTV to factory defaults.  The only solution was to reflash the JTV with the V1.70 firmware and then I was able to once more correctly select and store the model selection.

Is this a software glitch on either the X3L or the JTV59 and can it be fixed?  Thanks.

Re: JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-26 07:11:36.4450


Re: JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-28 06:48:52.2540

Bump.  This has been sitting here for 3 days without an update from Line6 Support.

I understand that the X3L has been discontinued but it is still supported - right?

And the JTV is the latest greatest Variax so it must be supported - right?

Well the JTV broke the X3L model select setting as described above. This can't be right and should be fixed.  The JTV is a current product which should work with all legacy products - so please can this be fixed to prevent it occurring in the first place and avoid the need to reflash the JTV to resolve as described above ?


Re: JTV-59 connected to X3L via VDI - model select function breaks
by davidb7170 on 2011-07-28 07:11:07.8310

I have a JTV-59 and the POD X3L, connected by the same VDI cable I've been using with my Vax300 for about 5 years. I've been gigging with the pair for 2 months since I got the JTV, and years with Vax 300 and the X3L, and XTL before that. My model selection and tuner functions with the X3L work for both Variaxes. I have both the Variaxes and the X3L with the most current firmware versions. I don't think what you are experiencing is a incompatibility problem from a design point of view, or something that the current firmware doesn't do of the devices, but a specific problem with your particular units, or a firmware install issue in your X3L or guitar -- guessing the X3L.... You may need to reflash the current X3L firmware if it didn't take properly. The revisions in the X3L firmware specifically added JTV interface support. You can't set the JTV model selection from the X3L gearbox software directly, though -- you need to set it from the input manipulation on the X3L unit itself. One other possibility could be the VDI cable itself...

my 2 cents.


Re: JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-28 08:58:59.4810

Thanks very much for your input Dave.

Just to clarify, I have been successfully using my Vax 700 with my X3L for the past year without any issues.  My X3L was at the latest firmware level and had all the JTV extra's installed before my JTV arrived.  And I am aware of the fact that currently Geabox does not allow you to select JTV model selection. My JTV works perfectly well with my X3L, except in the above instance when it got screwed up and the MODEL SELECT function from the X3L just did not work. 

I resolved the problem by reflashing the firmware on the JTV - which fixed it - but that indicates to me that this was caused by a problem with the JTV interface/software and not the X3L, therefore, I think Line6 should identify the fault and if it is a software issue fix it, or if it is an operational issue (eg: me unplugging the VDI from the JTV while still connected to X3L) then document what NOT to do, so nobody else gets hit by the problem.

Thanks again.

Re: JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-29 01:16:45.7010

If anyone else has experienced this problem or another issue where the JTV to X3L communication became unresponsive then please can they update this thread with brief description of issue and how they resolved it and whether it occurred just the once or more.  Thanks very much.

Re: JTV-59 connected to X3L via VDI - model select function breaks
by Nick_Mattocks on 2011-07-29 03:26:32.9140


I have an X3 Live here - it's an original one from the very start - I bought it in early November 2007 just after they were released.  I did experience the 'squeal' issue with it once or twice, but then I realised I was using my older POD 2.0 PSU - I have a number of PODs/Variaxes/M13 etc... and therefore a number of seemingly the same PSU's so I'd just picked out the first one that came to hand.  The POD 2.0 PSU I have is only rated at 1200mA so the cause of my squeal issue was a simple lack of current.  The correct 2000mA rated PSU works fine.

I don't use the X3 Live much at all these days as I have an HD500, but I have tested the JTV-59 with my X3 Live with a few days ago being the most recent and I have not experienced any issues such as you are describing.  I do know that some users have sometimes been unable to boot their POD X3 Live or their POD HD500 when a Variax has been connected - but this mostly seems to have related to the older Variax models.

From your description, the issue seems to have been something related to the guitar's firmware getting corrupted rather than the X3 Live itself, but I suppose there is an outside chance the issue may have been caused by a power issue from the X3 Live to the guitar 

When the issue first occurred, something had obviously caused the X3 Live to partially lock up and disconnecting the guitar did not stop the buzz either - is that right - or did the buzz stop when the guitar was unplugged but start again when you plugged it back in?

I am inclined to suspect some kind of power related issue, but that's only based on my own experience of the old 'squeal' thing really and other reported instances where a POD would not boot when a Variax was connected.  However, power issue or not, I would not expect it really to fritz the guitar's current firmware installation, so maybe it is more about the guitar than the X3 Live.  If the same thing doesn't happen again within a week or so, I would expect it won't ever happen again, but it is good that you've documented your experience in case others do get the same problem and then perhaps a cause might be found.  it's obviously difficult where there is only one isolated occurrence. 

But I will certainly connect up my JTV-59 to my X3 Live again and follow your recipe to see if I can reproduce the issue, but there's no guarantee that I will get it to happen.



Re: JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-29 06:40:24.9370

Thanks for your comprehensive reply Nick.  I have only ever had this happen to me once, so I would not be surprised if you can't recreate it.  And as for the noise, actually it was more of a high pitched squeal rather than a buzz - not sure why I described it as a buzz.  I definitely had the correct power supply as I only have the X3L.  I tried connecting it up again just now to my EL84 20/20 and all seemed fine except every once in a while I got that srange squeal - almost like a kettle just coming to the boil on the gas - but it was when I wasn't palying and wasn't there all the time like before.  So I don't know what that is - but I don't get it when I use the X3L connected to my powered PA speaker.

As for my other problem with the X3L tuner failing if I have the JTV plugged in to the VDI when I power on the X3L, well I can recreate this every time. I even tried using a different VDI lead and the same thing happens. Tried the same thing with my Vax700 and everything works fine - but with the JTV the Tuner just freezes on that first screen with the B highlighted.  Very strange.  But if I plug in the JTV after the X3L has powered up then no problem at all.

RE: JTV-59 connected to X3L via VDI - model select function breaks
by Line6Don on 2011-07-29 11:38:29.4160

Hey edstar1960,

The buzzing could be related to your input selection screen, if you have multiple inputs enabled but are only using the VDI, the other inputs are still active and waiting for signal.

I tested a JTV59 with flash memory 1.70 with a POD X3 Live with flash memory 2.01.

-I loaded up the input selection/ JTV model selection page.

-Change models using the POD X3 Live encoder knob and the JTV on-board model selection knob, POD X3 Live registered the changes from both.

-Disconnected and reconnected JTV.

-Closed and reopened the input selection/ JTV model selection screen and the functionality remained. I was able to change models using the POD X3 Live encoder knob and the JTV on board model selection knob.

This problem is most likely due to an issue with your flash memory. Reinstalling the latest flash memory for both the POD X3 Live and the JTV-59 should address this issue.

Re: RE: JTV-59 connected to X3L via VDI - model select function breaks
by edstar1960 on 2011-07-31 04:01:22.8900

Thanks for trying to recreate this issue Line6Don.   It only happened once to me and it may have been a specific combination of button pushes that caused it - the guitar was new and I was still getting accustomed to it. 

It is good to know that this problem should not occur but in case it does then at least it is documented in here how to get around it, as explained in my original entry, the reflash of the JTV resolved it and it has not reoccured.

The information above may not be current, and you should direct questions to the current forum or review the manual.