These forums are read only, please use our new forums here.

Main :: Spider IV/Spider Online

My amplifier is stuck on the "Ready To Update" screen.
by Leveler on 2011-07-30 00:35:11.4560

I attempted to update my Spider IV's flash memory 3 times, and after it failed the third time, it just displayed an error message.

I restarted my amp, and now it's just stuck on the "Ready To Update" Screen, and won't snap out of it! Can someone help me get my amp operational again?

Re: My amplifier is stuck on the "Ready To Update" screen.
by Nick_Mattocks on 2011-07-30 11:52:52.2470

Mine did this when I first tried to update it two years ago when I got it. I haven't got a lot of time right now to write up a detailed reply (band meeting in ten minutes...) but the process has partially completed and you need to re-flash again.  make sure you are connecting the USB cable from your FBV II board directly to a USB 2.0 socket - don't use a hub!

Sorry gotta go, but post back if you're still having problems and I should have more time :-)


Re: My amplifier is stuck on the "Ready To Update" screen.
by Leveler on 2011-07-30 12:14:01.5490

Alright, I've tried again. But I keep getting the same error:

Error (80009000) Unknown MIDI error

I've made sure to close any other programs that could be using MIDI, but the error will not relent!

And as a sidenote, Line 6 Monkey does not know what my current version of Flash Memory is... It is marked as 'Unknown' while the latest version is 2.00. Luckily, I won't need to use my Spider for a couple more days though, so I have plenty of time to fix it!

Re: My amplifier is stuck on the "Ready To Update" screen.
by Nick_Mattocks on 2011-07-31 00:26:56.2930


Sorry I didn't get back to you last night.  Band meetings do tend to go on a bit - especially when there's alcohol involved LOL (not me - I was driving)

Yes - that error is caused by the FBV shortboard/Express not being able to communicate properly by USB, so the problem you have is almost certainly going to be between the computer and the FBV.

In my case the issue was with my windows XP installation (remember this was about two years ago for me) on one of my computers - an Acer Travelmate 8104WLMi laptop running Windows XP Pro onto which I had installed a Logitech Webcam a wile before - and which turned out to be significant.

The Logitech Webcam was not even connected BUT the driver was still installed and Windows was loading part of the driver at start-up which was blocking proper communications with the FBV and therefore blocking proper communications with the amp.   I switched to another laptop (a Toshiba also running XP Pro) and the process worked perfectly.  I spent a morning comparing Windows installations and troubleshooting the cause and discovered the link between the Logitech driver and the problem, and once I stopped Windows accessing the Webcam driver files, it then allowed proper communication with the FBV Shortboard and the amp.   I don't know if you have a Logitech or other Wewbcam (built in or otherwise) that might use elements of the same driver, but at least one other user has cured the issue by removing the drivers for their laptop's on-board Webcam - and that was an Acer Travelmate 8204WLMi laptop which has a Webcam in the lid whereas my 8104 WLMi does not have an on-board Webcam  (mine was the clip-on type).   Other users with Logitech Webcams on a variety of computers have also found problems with Line 6 FBV MkII Shortboard/Express installations.

OK the Webcam thing is something to check out.

The other thing to check is the firmware for your FBV MkII Express or Shortboard.  That has to be up to date too, and if it is still running the factory installed firmware version, it will possibly limit communications between your computer and your amp.

If you can use a different computer to update your amp in the first instance, that would be my advice just to get your amp back up and running quickly.

But the chances are that you only have one computer, so here's a few things to do which might help:

  • Update Windows (or Mac OS) with the latest service pack for your OS and apply any other updates. that might be available
  • Try a different USB cable
  • Try a different Ethernet cable between your amp and the Shortboard
  • Unplug all other USB peripherals from the computer
  • Try a different host computer for the update just to get your amp back up and running ASAP
  • Try an inexpensive PCI/PCI-Express, PC card/PC Express card (laptop) USB 2.0 interface
  • Ensure that the USB port you're connecting to is USB 2.0 compliant
  • Do not connect to ANY form of generic USB hub - internal or external
  • Connect to a rear USB 2.0 port on a tower or desktop computer
  • Temporarily disconnect/disable any wi-fi network interfaces
  • Temporarily disable anti-virus software (whilst being disconnected from the Internet)
  • Download the flash memory file to your computer and useMonkey's Update from file feature.
  • Boot the amp in diagnostic/Test mode and try flashing - hold down TAP as you turn the amp on
  • Ensure the mains power supply to the amp and computer is clean - extraneous power line 'noise' might cause a problem

Don't worry too much about Monkey not knowing which version of the Flash Memory is installed.  I am assuming your amp is currently inoperable as you have tried updating several times and failed.  The update process initialises the on-board EEPROM which contains the firmware (flash memory) code and then writes the new code to it.  The code is streamed from your computer as MIDI information, but uses the FBV MkII Express/Shortboard as a non-standard MIDI interface to do the job.  The likelihood is that you have started the initialistaion process which will have partially or fully erased the firmware from the amp's EEPROM thereby rendering it useless until it is properly updated and because of that Monkey won't detect the flash memory version installed - because there is no flash memory installed any more.

If none of that works, then your amp may be defective, in which case you will need to book it into an Authorised Service Centre (ASC) for diagnosis and repair, but I doubt the problem actually lies with your amp and is more likely to be attributable to one of the things I've listed above.  For speed, using a different computer to perform the update might be your best option.  If your computer is a Mac, try to find a PC to perform the update right now, and worry about sorting the Mac out later - I don't 'do' Mac unless I have no choice in the matter, but others do.

Good luck with this.



Re: My amplifier is stuck on the "Ready To Update" screen.
by fflbrgst on 2011-07-31 03:44:27.4650

There are a bunch of threads in the FBV section of this forum on the same problem - check them out.  I was finally able to update by using a different computer - one running XP instead of Vista.

Re: My amplifier is stuck on the "Ready To Update" screen.
by Leveler on 2011-07-31 22:49:09.0680

Oh no, I understand on the band meeting thing. Sometimes, we practice for like an hour than sit around playing everybody elses instruments for 3 more!

And as it turns out, I happen to have two other computers! I have a laptop with Vista and a Tower with Windows 7 as well as my laptop running Windows 7 (My usual laptop). When I ran the Flash Update on my Vista OS, it worked on the first time around! I have no idea what it couldv'e been though... But that's ok, because I'm all fixed up!]

Thanks for the support!

The information above may not be current, and you should direct questions to the current forum or review the manual.