These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort

Pod Studio UX2 Not Detected by Monkey in Mac OSX
by OsirisGrave on 2011-09-21 05:22:56.1570

The Line 6 Monkey for Mac OSX does not detect the Pod Studio UX2. There have been so many reports of this problem throughout the past several YEARS. Yet Line 6 has not fixed it. , , or ,

I have OSX 10.7.1. Several users have identified the problem.

Cause: Let's break down how Line 6 Monkey works (at least that's what I think it does):

When you run it for the first time, it connects to the internet to download some kind of device definitions, which is a good thing because it should always stay up to date. If it does not detect an internet connection it uses a built-in database of device definitions (they are integrated in the software, on a Mac inside the Line 6 So far so good. But if Line 6 at least once connected to the internet and downloaded the definitions, then it never uses the built in database, even when there's no connection, instead it uses previously downloaded database located in Library/Application Support/Line 6/default.cfg.

And that's where the problem appears, when the Mac version of the software connects to the internet for the first time it download a bad database (very old one, only with three devices mentioned earlier, it's located here: ) therefore from now on, even with the internet connection down, it uses this bad database and doesn't work with other devices.I'veverified it by copying the good database from inside the app to Library/Application Support/Line 6/default.cfg and shut down my connection (in order to force the app to use the good database). Then it all worked on my mac, my device was recognized and could be authorized. But when I tried to run with internet connection on it downloaded the bad database and from that point on it refused to work again. So it cannot be fixed without changing the way this software works.

I've also noticed that other people who have this problem (from the links I've provided) attached their log files. In everyone of them (including mine) there was this line:

     Redirecting to: (this is the old database)

Which makes me almost certain that this is the issue.

Solution: There has to be a problem with the way mac version downloads the database. I think I found why:

The URL it tries to connect to in the mac version is as follows:

But in windows version it is: So maybe it should be changed somewhere inside the app

Probably it's a very easy thing to fix, and I wonder why it hasn't been fixed so far. Because of this error I cannot authorize my device on this computer, and use every feature I've paid for.

Can you please fix this in the next update?

Re: Pod Studio UX2 Not Detected by Monkey in Mac OSX
by OsirisGrave on 2011-10-27 17:20:33.8780

Nevermind. I was able to fix it. The problem had something to do with Chinese Internet connection. Once I connected on a VPN it started working.

The information above may not be current, and you should direct questions to the current forum or review the manual.