These forums are read only, please use our new forums here.

Main :: James Tyler Variax Guitars

Support community for JTV.

Issue with registering JTV 69
by mkrohne on 2011-10-15 16:16:04.0210

I am reposting this 'cos I think the original question was in the wrong spot. Is the right one?

I have registered my JTV 69 online and my account shows that it is registered, however, the Workbench software will not recognize this JTV 69 as registered. So I can't use the software. What can I do to fix this?

BTW. I did not have this problem with my JTV 59.


FOLLOW-UP November 13, 2011

Sometimes waiting solves things - if you wait long enough.

For some reason, the problem resolved itself - mostly. I use a Mac and upgraded to the new OS - Lion. I have the newer version of Workbench (1.72.0, build 120). After a few tries recently (see last post) Workbench recognized my JTV 69. It worked - but very slowly. Poor performance may have been due to the Java exception noted in my last post below.

I have not tested yet to see if Workbench recognizes the JTV 59 as well. If it doesn't, I will re-post this. Off to rehearsal now.

Re: Issue with registering JTV 69
by Troubadour on 2011-10-16 12:03:04.2920

Hope we get an answer here.

When registering my variax 600 online there was a box to check indicating the color of the guitar, this added some nubers to the serial number. I seem to have too few numbers to properly register my JTV69


RE: Issue with registering JTV 69
by Line6Don on 2011-10-18 14:49:43.2590

Hey mkrohne,

Is it possible for you to include a screen shot or detailed description of the error message that Variax Workbench is producing when you try and launch it with your JTV-69 connected?

How are you connected the JTV-69 to the computer? Variax Workbench interface or a POD?

Re: RE: Issue with registering JTV 69
by Troubadour on 2011-10-18 15:31:32.7770

This is Troubadour,I can launch workbench, but if I have line6 monkey on and check for updates for the JTV69

I get a box to click that says register product now? and that will go the register product page, or a box that says remind me later?

I thought I had it registered. Guess not

Re: Issue with registering JTV 69
by yuriamorim on 2011-10-18 23:06:25.2140

I'm having the same problem. I have a korean black JTV 69.  It was successfully connected to the computer trough the USB interface and then I got the box asking me to register it (inside Line 6 Monkey). I've created my account in this website and after that the registry was properly done (so it's shown up into my registered gear). Even though, the Workbench software keeps asking for it's registry. It doesn't recognize the one that is available on the website. I really want to go into the Workbench, but this issue is on my way. What should I do?

Re: Issue with registering JTV 69
by edstar1960 on 2011-10-19 01:23:10.5460

I believe this is a well known issue.

I understand the resolution is simply to click on the REMIND ME LATER button and then you should be able to download updates via Monkey or enter workbench.

Is that not the case?

Re: RE: Issue with registering JTV 69
by mkrohne on 2011-10-20 05:21:24.4240

The JTV 69 connection is through the the Variax interface. I can get a screen shot tonight. Basically it tells me that this guitar is not registered. Oddly, when I check my account in the Line 6 site, that guitar shows as registered. I thought it might be a latency issue at first, but when I checked later, there was no change.

Re: Issue with registering JTV 69
by mkrohne on 2011-10-20 05:25:23.9810

I updated Workbench with Monkey, but that did not help. I can open Workbench, but it won't read the settings on my JTV 69, so I can't modify anything.

Again, I did not have this trouble with the JTV 59: same interface, same software, same registration on Line 6. Workbench works with the 59, NOT the 69.

What's up? (Patiently waiting in Atlanta)

Re: Issue with registering JTV 69
by yuriamorim on 2011-10-21 12:01:45.0500

No. That's not the case, Ed.

Actually, I have the very same problem related by mkrohne. Mine JTV 69 is already registered (I can see it on "my registered gear"), even though it seems that Line 6 Monkey doesn't recognize it.

When I first had this error I've clicked on the Remind me later, and then I could sucessfully update my firmware.

But when I open the Workbench software it just doesn't recognize my JTV at all. As I told you, I'm running it trough the Variax USB interface (with both sides having the green lights lit). I try to refresh, but it never works. I've already tried to add it manually, but it just gives me "offline" acess to the program. This way I can't load anything to the guitar, as well as modify the factory presets.

It makes me think that the problem could possibly be the non-recognition of the registered gear by the Monkey software, assuming that the Workbench asks for its connection.

I'm including a screenshot. Hope that helps to figure it out what the problem is.

(Patiently waiting in Brazil)

Re: Issue with registering JTV 69
by yuriamorim on 2011-10-21 12:11:08.8270


RE: Issue with registering JTV 69
by Line6Hugo on 2011-10-24 15:04:01.6060


Can you please provide us with that screenshot so we can understand the problem? Workbench never asks about the registration of the guitar, so we want to make sure you are seeing what you mentioned by seeing a screen shot.



Re: RE: Issue with registering JTV 69
by Line6Tony on 2011-10-28 09:23:05.9880

Hello. It has been at least 72 hours since we've heard from you. We're going to assume your question has been answered and close this thread. If you feel your question(s) have not been answered, or, if you have further questions, please feel free to re-open a support thread within our support community and we will answer your questions accordingly. Thanks!

Re: RE: Issue with registering JTV 69
by yuriamorim on 2011-10-31 17:59:09.6760

It seems that I've been ignored here... Do you Line 6 guys just answer to the original poster of the thread??? I had the very same problem. I provided the screenshot, but apparently you didn't notice. Should I open a new thread so I can have attention?

It doesn't makes sense to me (as the problem is the same early reported).

(Less and less patient, but still waiting in Brazil)

Re: RE: Issue with registering JTV 69
by mkrohne on 2011-11-12 17:37:31.6120

I apologize for the very long time it has taken me to get back to this.

Up to now, I've just been working with the defaults on my JTV 69. Tonight I decided to try Workbench again. Screen shots below. I did NOT open Monkey this time.

Here is a Java error I got tonight:

An exception was caught.

java.lang.NullPointerException: null

App info: Variax Workbench 1.72.0 release - build 120 - Mon Aug  1 19:55:43 PDT 2011

Date: 11/12/11 7:51 PM

In thread: Thread[AWT-EventQueue-0,6,main]

OS: Mac OS X (10.7.2 i386)

Java VM Version: 1.6.0_29

Stack trace:


          at modules.variax.editor.L6VariaxEditor.UpdateTuningPanel(Unknown Source)

          at modules.variax.editor.L6VariaxEditor.OnConnectionStatusChanged(Unknown Source)

          at line6editbase.editor.L6Editor.UpdateConnectionStatus(Unknown Source)

          at Source)

          at Source)

          at Source)

          at Source)

          at Source)

          at Source)

          at variaxworkbenchapp.L6VariaxWorkbenchApp.OnAction(Unknown Source)

          at Source)

          at cmn.l6java.gui.L6ActionListenerThread.actionPerformed(Unknown Source)

          at javax.swing.AbstractButton.fireActionPerformed(

          at javax.swing.AbstractButton$Handler.actionPerformed(

          at javax.swing.DefaultButtonModel.fireActionPerformed(

          at javax.swing.DefaultButtonModel.setPressed(

          at javax.swing.AbstractButton.doClick(


          at java.awt.MenuItem.processActionEvent(

          at java.awt.MenuItem.processEvent(

          at java.awt.MenuComponent.dispatchEventImpl(

          at java.awt.MenuComponent.dispatchEvent(

          at java.awt.EventQueue.dispatchEventImpl(

          at java.awt.EventQueue.access$000(

          at java.awt.EventQueue$

          at java.awt.EventQueue$

          at Method)



          at java.awt.EventQueue$

          at java.awt.EventQueue$

          at Method)


          at java.awt.EventQueue.dispatchEvent(

          at java.awt.EventDispatchThread.pumpOneEventForFilters(

          at java.awt.EventDispatchThread.pumpEventsForFilter(

          at java.awt.EventDispatchThread.pumpEventsForHierarchy(

          at java.awt.EventDispatchThread.pumpEvents(

          at java.awt.EventDispatchThread.pumpEvents(


Here are screen shots that got me there:

Workbench on with the JTV 69 attached through the Variax USB interface:

Workbench 1.jpg

Click on "Configure" in menu and make a selection (after a long wait).

Workbench 2.jpg

Get an error (complete text is above):

Workbench 3.jpg

OK, so I dismissed the Second error message and clicked on Refresh. This first time I tried this, nothing happened.

Workbench 4.jpg

And yet, strangely tonight, for some reason. Workbench (not at first, but eventually very slowly while I was typing this note) started to read my JTV 69.

Workbench 5.jpg

I am totally confused. I hope it still works with my JTV 59.

I will report back on whether or not Workbench continues to work.

Re: Issue with registering JTV 69
by mkrohne on 2011-11-12 18:06:00.5280

This is exactly what I was seeing when I first wrote this post.

Re: RE: Issue with registering JTV 69
by mkrohne on 2011-11-13 06:10:44.5440

I apologize for the long delay. I've not been able to get back to this for a while.

The information above may not be current, and you should direct questions to the current forum or review the manual.