These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort

UX2 not detected by Monkey or Windows
by Natster on 2011-11-23 10:16:48.4610


The Line 6 Studio UX2 which I purchased earlier this month suddenly stopped working two days ago.

After a few weeks of trouble free use, the device stopped being recognised whenever I plugged it in - I know power is still being supplied to the UX2 as the two needles on it jump up vertically whenever it is plugged in, but no lights appear and it doesn't appear in Windows Device manager.

I went on the Monkey software and saw there was a driver update for the UX2 available. I assumed that installing that would fix the problem. The driver installation appeared to go smoothly up to the point when you have to plug in the device and let Windows hardware installation start. However, after plugging the UX2 in again, the "new device detected" dialogue didn't appear.

I just can't get Windows or Line 6 Monkey to detect when the device is plugged in. I've searched through Device Manager and clicked "Scan for Hardware changes" in that menu (occaisonally I do get an "Unknown Device" - presumably the UX2 - appearing in the Device Manager); reinstalled all the drivers; reinstalled all the  Line 6 software on my PC as well as drivers; tried removing all the other USB devices (other than mouse and keyboard) and then reinstalling the drivers and plugging the UX2 in different USB ports on my computer.

The best I have been able to do is get Windows to the stage where it says there is an "Unknown Device" (which I presume is the UX2) by clicking on something like "scan for hardware/device problems". It then says something like "device driver not found" even when I have checked in my program files that the UX2 drivers are indeed present.

I am not sure but I have had issues with other USB devices from other manafacturers whereby upon uninstalling they leave behind old files in the Registry which then cause issues for trying to reinstall the devices.

My system is:

Intel Core i7 920 @ 2.8 GhZ


Windows 7 64 bit

USB 2.0 and 3.0

I would really appreciate any help with this so I can spend less time on the Keyboard and more on the Fretboard!



Re: UX2 not detected by Monkey or Windows
by Triryche on 2011-11-23 12:48:36.6840

Great description of what steps you have taken so far.

Try this just in case (you certainly already did a version of this).

Make sure you are signed on as administrator.

Go to the Line6 Folder and find the "Uninstall Tool"

When you run it check to remove all drivers that you can see.

Then download and run the newest drivers for your OS (Just drivers, no Monkey yet).

When you run the driver install program make sure the UX2 is NOT plugged in.

When you are prompted to plug in the device if Windows gives a warning, choose "install anyway" (I forget the exact dialog)

If you get past that then run the newest version of the Monkey

Re: UX2 not detected by Monkey or Windows
by Natster on 2011-11-24 09:05:37.9040

Thank you very much for your answer.

I did as you said and managed to at least get the message "Installing device driver software" (something like that) to come up. Unfortunately, it fails and says "No driver found"... I have been able, by going onto the device manager, to manually browse for the drivers for the "unknown device". After selecting the UX2 driver file location, I only get a message saying "Windows could not find device driver for your device..."

The problem seems to be Windows not being able to find the drivers, despite them seemingly being installed. At least some driver files are present in the C:\ProgramFiles(x86)\Line6 folder\Tools\Driver Archive\UX2 location, so perhaps it is an incompatibility with Windows 7 64 bit or an issue with the installation? Any futher tips or suggestions would be greatly appreciated.

Thanks again!


Re: UX2 not detected by Monkey or Windows
by Triryche on 2011-11-24 22:57:32.4110

Try different USB ports.

Also try a different USB cable.

If possible try to install the drivers on a different computer. If it installs successfully on another computer you can rule out the problem being the UX.

Re: UX2 not detected by Monkey or Windows
by Line6Tony on 2011-11-30 15:07:37.9230

+1 Triryche on trying another computer. Also, this is not an incompatibility issue, as I have a UX2 on my Win 7 64 machine right now. It is likely a configuration issue on the computer. Please see our USB Audio Troubleshooting FAQ at for things to try that have helped others with configuration problems.                  

Re: UX2 not detected by Monkey or Windows
by Natster on 2011-12-03 11:02:08.3020

Thanks for both of your replies. I tried all of the applicable steps on the link you sent about USB troubleshooting and tried installing the UX2 on a different computer (just installing the drivers - no monkey) and I encountered the same problem - the device was just not being detected. Unless there are any other suggestions - perhaps I am installing it wrong? - it would seem to be an issue with the device itself. Any other pieces of advice would still be greatly appreciated though.


Re: UX2 not detected by Monkey or Windows
by kirias on 2012-09-06 12:32:27.9140


The information above may not be current, and you should direct questions to the current forum or review the manual.