These forums are read only, please use our new forums here.

Main :: M5 / M9 / M13

m5 flash went into flash update mode all by itself
by cosmojones on 2012-03-30 12:30:31.1240

That pretty much says it. I connected it to Monkey and reinstalled the flash memory, but what's up with that?

Re: m5 flash went into flash update mode all by itself
by darealagentp on 2012-05-25 14:23:21.8380

I'm not sure what caused the "Flash Update Mode" display text. But the unit is driven by the Flash Memory (M5's operating system software), so a reinstall of it should reload all the software.

Re: m5 flash went into flash update mode all by itself
by cosmojones on 2012-10-31 22:26:20.9350

This thing gets stuck into this every few weeks. I thinks it's a piece of !@%#&@#!. I can't step on it without it acting up. Is this how service is supposed to work? You get a response 2 months later? This thing has never worked right. Just when I'm about to chuck it out or take it back it starts working again. It started messing up after about a month. It worked again for about 2 months after reloading the flash. Now the frequency of this is every other day. Checking with other posts this looks like a common problem. To be honest, I think the power supply that it comes with is not enough for it. I've only used the supplied power supply.

Re: m5 flash went into flash update mode all by itself
by cosmojones on 2012-11-01 15:05:05.5520

OK - here's the issue (you can find it on several other posts): M5 won't boot, rapidly switches on and off, often reboots when you step on it, often people send it back with no solution, etc.

Mine started acting up almost immediately and the problem is intermittent - I've gotten no real response from anyone, and now it's out of warrenty - SO I TOOK IT APART.

I am a trained electronics technician and here's what I believe is wrong with it - it's a relatively easy fix, I believe it's a grounding issue. This is what I've done and it now appears to be working:

1. Remove the 4 rubber feet and their screws. Also remove the countersunk screw on the side holding the MIDI port.

2. Go to a hardware store and get new UNPAINTED replacements - throw the rubber feet away along with all the painted screws.

3. Take sandpaper or a file or a knife and either scrape or sand away the paint from all wholes underneath where the screws will touch. I used a knife to scrape away and a drill bit held in my hand to shine up the surfaces. Those who are more intrepid might want to take the entire back off and shine up the surfaces where the grounding lugs touch the chassis. Do not get filings into the circuit board.

4. Snug up all screws with the new unpainted screw making sure all screws are now making metal to metal contacts.

I believe the power supply is grounded through the chassis. Stepping on the pedal squishes the rubber feet breaking the contact of the circuit board studs to the chassis. Good luck. Mine now works.

Re: m5 flash went into flash update mode all by itself
by modenessi on 2013-02-07 15:16:59.6080

Thank you for taking the time to put that up!  It seems to have gone back to working normally. I forgot to do the MIDI port screw and it still worked.  I had removed the feet and not replaced the screws to mount on a pedal board.  It worked but started acting up untill i mistakenly used the power source of another pedal.  It flashed and seemed to work when I put the proper cord back in.  Later, it pooped the bed! I followed the instructions after finding out I was out of warranty, and was pleasantly surprised that the fix was so simple.  For the record, #6-32 x 3/8 round head combo machine screws, in case you have thrown out the feet and screws already, as I had.  A drill with a wire wheel makes short work of the paint around the screw holes.  Nice and tight like Cosmojones said.  Thanks again, I feel you saved me a couple of hundred bucks and just wanted to add the details on the screws in hopes to pay forward you time and consideration.

Rock on!

Big Mo

Re: m5 flash went into flash update mode all by itself
by DoubleVirgo on 2013-02-27 15:10:36.5740

Is this fix still working for you guys? I'm having The Problem and am thinking of trying your idea.


The information above may not be current, and you should direct questions to the current forum or review the manual.