These forums are read only, please use our new forums here.

Main :: POD HD

Support forums for all POD HD products

POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-12 20:53:37.8260


I just received my HD300 from Musician's Friend today. After listening to the factory presets, I decided to take the manufacturer's suggestion, register the product and update it. I'm begining to think that was a mistake, however, as the POD just lays there and does nothing now. This problem seemed to occur with the flash memory update. Monkey shows v. 1.31, but simultaneously shows NOT installed. Factory resets of the unit have been unsuccessful with DSP Boot Failure and a blank screen. I've tried everything from using every available usb port to reinstalling drivers, etc. I would reinstall the flash memory, but Monkey won't let me have that option for some damned reason. Reinstall Latest is grayed out and the option to install from file is, oddly enough, not available. It simply isn't there.  After reading multiple threads dealing with this issue and spending about 4 and a half hours trying this and that, I have to say I'm pretty damned disappointed with this product. Posting to this forum is my last ditch effort to get this resolved before sending the unit back. I hope to God someone can help me resolve this, because I really don't want to return it. I just want the unit to work properly.

Any help is greatly appreciated.


Re: POD HD300: Unable to update flash memory
by TheZiv on 2012-06-12 21:38:50.2110

I'm in the same boat that you're in. I'll keep my eyes on this post, hopefully we can get this resolved.

Re: POD HD300: Unable to update flash memory
by silverhead on 2012-06-13 06:55:11.6750

Do you have access to another computer just to try for updating the firmware? I have seen this symptom occasionally and sometimes a change of computer/OS helps.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-13 07:15:03.0180

Thanks for the response. I do have a laptop, but not sure if the OS is compatible on that machine. I'm running Linux on that one and to my knowledge Line Six doesn't have a compatible download for that, although they do have Mac. While Mac and Linux are quite similar, I've read that their OS isn't binary compatible. Therefore, I probably won't risk trying to update on my laptop unless you can tell me that this is doable through a Linux architecture. Not sure I have anything to lose, though. At this point, my unit is pretty much a giant, glorified paperweight. Any other suggestions?

Re: POD HD300: Unable to update flash memory
by silverhead on 2012-06-13 07:27:08.2820

No - Linux won't work.

I suggest you open a support ticket for yourself directly with Line 6 tech support:">">

Select the Contact Technical Support link.

Another thing you might try in the meantime:

Download and install Line 6 Monkey version 1.53. Use that version to attempt the firmware update. You will find it under the Downlaods tab at the top of this page. Select Line 6 Monkey as the software and select your OS.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-13 08:39:40.0880

Thanks man. I went ahead and tried using v. 1.53 of Monkey (I had already attempted this multiple times with v. 1.56) to attempt a reinstallation of flash memory. I also reinstalled drivers...again. Results are exactly as before. Monkey thinks I have the latest version of flash (1.31) installed, but in the corresponding "installed" column there's only a dash and there's no option to reinstall or install from file. You'd think that option would be available in the event something goes wrong with installing flash memory. Oh well, thanks, anyway, for your help man. I'm placing a call to Line Six support as I type. If they're able to resolve this over the phone, I'll post the fix in graphic detail on this thread. Wish me luck.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-13 09:52:03.2580

Okay. After reporting this issue to technical support, I discovered that they apparently weren't aware of it. Support tested this with every available version of Monkey after I reported it. All versions had the same result. I was told that they were going to pass this on to the Line Six software team and that I should watch the download page or merely monitor it using my current version of Monkey for a new version or update which will resolve the issue of either reinstalling through server or installing flash memory 1.31  from file. As you know, those who are suffering from this issue are unable to do either after the flash memory update goes awry. According to Support, the issue lies with Monkey. I was told it might take as long as a week to get this resolved, after which we should be able to update Monkey to a version which allows you to reinstall flash memory or install from file in the event your flash memory update screws up. So for now...we wait.

Re: POD HD300: Unable to update flash memory
by jbut711 on 2012-06-26 18:01:40.1610

so i just picked up an hd300 today and i have the same exact issue. im using monkey v1.57 rather than v1.56 and i have the same persiting issue and i want to throw this thing thru a wall! i played around with it fine but i had to go and change something and now it's a vegtable. pleas someone help me out here.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-26 19:36:35.8780


Let me give you a little advice. Stop. Don't do anything else, you'll only make yourself absolutely crazy. I know because that's what I did. I spent hours searching the forums and trying like hell to fix this before I started this thread and took Silverhead's advice to report the issue to support. Instead of going through all of that, report your issue immediately to them.  Please tell them to refer to this thread, but that ALOT of Windows 7 users are suffering with this issue, NOT just us.

I finally got my new Line Six today after returning the factory restock unit I had before. But I am afraid of trying to update the drivers and flash memory because as far as I can tell, the issue still persists, which means an update will render my new HD300 useless. It's maddening and there's no telling when the fix will come. I don't see any way to install the flash memory from file (which would be my preferred way of doing it) much less updating from server. If you saw the date for when I started this thread, then you know, it's been 2 weeks since this issue was reported to tech support. They, in turn, turned this over to the software team. I was told to await an update which would fix this bug. One week of waiting is tough enough, but two weeks?  Anyway, you can bet your backside I'll be on the horn with them tomorrow. If I don't see an update to repair this problem with Monkey's compatibility and Windows 7 by week's end, I'm putting this one back in the box as well and  returning it for a refund. This is beyond ridiculous and I think I've been more than patient. Everyone has their limitations.

Re: POD HD300: Unable to update flash memory
by silverhead on 2012-06-26 20:06:53.3080

Have you tried restarting your PC? That may help re-initialize the USB ports on your computer, and Monkey may then be able to recognize the installed HD300 firmware. Once it recognizes the installed version (no more dash) you should be able to update/reinstall.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-26 21:22:10.1320

No I haven't restarted, but my issues weren't related to my pc detecting the device. It seemed to do that just fine. It was that annoying little dash and the grayed out button with no other option for installation. However, I do have a bit of good news. Took several updates on Monkey and it looks like the option to install from server or file is, now, working. (THANK YOU LINE 6) I'm still scared to try it from server. I went ahead and dl'd the flash memory update to my local environment, so I can install it from file. However, I don't know where the firmware file is. I checked the downloads page, but didn't see it in the list. Drivers seemed to update just fine. I'm going to attempt to update the firmware from server and then update flash memory from file now that it appears to be working. If it fails and I get no options for reinstallation, I'll know that it's still broken. I have no idea why it didn't want to update the first time around. For some reason unbeknownst to me, the second time I plugged it in was when it asked if I wanted to update Monkey and that's when my install option buttons came back. So I guess I owe those guys an apology...if it works:) The verdict is still out on that one. I'll let you know tomorrow. Thanks for all your help silverhead...and your patience. This has been THE worst experience I've ever had with a piece of outboard gear.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-27 10:12:17.2220


Okay. Here's where we stand. After updating to Monkey 1.57, I was finally able to update flash memory for the POD hd300 and everything appears to be working. If you're a Windows 7 user and you've been struggling with this, you have my sympathies. Obviously, I'm no expert, but here's my recommendation and I'll leave corrections to silverhead or another competent community/techminded person, who is.

First, it looks like Line 6 has updated Monkey to now allow reinstallation of the flash memory either from server, from file, or with an option to roll back to an earlier version. The latest version, which resolves this conflict with Windows 7 is available (1.57). (BTW, I need to say nice job Line 6 Software Team...and a huge THANK YOU from the bottom of my heart.) Anyway, you Windows 7 folks will have to update to Monkey 1.57+. That's first. Easily done with a few clicks from your desktop after installing Monkey. If you have a much older version, you'll have to repeat this process a few times to bring you up to speed, as every time you open Monkey, it will ask if you want to update it until you are current with the latest version. Just do it until you're current.

Second, you'll need to make absolutely sure you're using a root/dedicated 2.0 port if you're planning on updating your POD. If you're a Dell Inspiron user like me, then I wouldn't trust the USB ports for updating the flash memory, even the ones in the back. Everything else seemed to update fine from through the rear USB port. But due to all the hell I went through in trying to update flash memory from before, I took no chances and downloaded the flash memory update to my local machine this time around. After you've downloaded it and placed it on your desktop, go into Monkey and if drivers and firmware are good to go, highlight  flash memory, choose the install from file option, this will open another window for navigating to the file you just placed on your desktop. Select the file and install it. Monkey will do everything else. Takes a while to do that update, so go grab a beer and chilax while it's working:) It will prompt you when finished.

Oh one other thing I discovered in testing this. If your POD HD300 EDIT software is open, at the same time when you open Monkey, you will see the dreaded dash symbol in the Installed column where your version number should be. Basically anything else which is using your POD must be closed when you're doing the stuff with Monkey if you want things to appear and/or work correctly. I think Line 6 has explained this elsewhere, but you won't get a prompt by just opening Monkey up while your EDIT software is open. So if you're getting the dash of death in that Installed column next to flash memory, be sure that your EDIT software is closed. Also, if that's your situation, after you close your EDIT application, I would restart Monkey and see if it now detects your flash memory version properly.

That is all. I hope this helps at least one other person struggling with this thing. If it helps you, let me know about it. CHEERS!

Re: POD HD300: Unable to update flash memory
by bclarke675 on 2012-06-27 10:47:27.6220

Thank you for sharing what finally worked for you.  I have an HD300, and am looking forward to the 2.0 update, but was getting a little concerned about whether it would be smooth.  Probably no problem for me, since I'm running Win XP Pro, but still good to know, all the same.  My other laptop is running Win 7, so it will probably help there.

Too many get their problem solved, but don't let us know how.

Again, I appreciate your reporting what worked!


Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-27 10:52:42.3060

Thanks Bob. If this helps you or someone else, be sure to mark it as a "correct answer." It will help others who have similar issues find it easier. Good luck to you on the 2.0 update. I had seen where that is available for the 500 and hd pro users, etc. but not the 300 users. I'm hoping they will release that for 300 users as well. We'll see...

Re: POD HD300: Unable to update flash memory
by bclarke675 on 2012-06-27 10:58:02.5360

You're the only one who can award Answer Points, so give yourself the points for Correct Answer (or Line 6 support or silverhead), whoever helped you most.  It's your post, so you determine the Answer Points.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-06-27 11:58:41.1620

oh. Duh:) Thanks Bob. Will do.

Re: POD HD300: Unable to update flash memory
by jcshelby500 on 2012-10-26 07:34:59.8380

Just Bought HD300. Tried update. Everything went smooth except flash update. It crashed the unit and gave the "DSP boot failed" message. I was able to roll back and the unit seems to be working. Its OCT 26, 2012. Have they not fixed issue? What happens if I choose not to update the flash memory?



Re: POD HD300: Unable to update flash memory
by bclarke675 on 2012-10-26 07:43:08.6440

I didn't have an issue when I did my update.  Try a different computer.  That's the best suggestion I have.  I don't believe it's the upgrade causing the issue.

Nothing will happen if you don't do the just won't have the new amp models.  And you should revert back to the previous version of HD 300 Edit to be compatible.

Re: POD HD300: Unable to update flash memory
by Sumatra_Gold on 2012-10-26 09:17:03.8670

Before you can do a flash update, you need to ensure that you're using a root USB port and not a hub. Most windows machines don't have a root usb in the front of the computer. Some of them have no root usb port at all on the outside of machine...only the hub type, which is basically where the root usb is inside the machine. From there it has ports which Y off of it and are accessible from the outside. You'll have to experiment using a usb port in the rear, most likely. Be sure you don't have your POD Edit software running in the background or you'll have issues. Also, don't update your flash directly from the Line 6 site. Instead, download the flash update directly to your desktop. Then use Monkey to "update from file." Select the downloaded flash update from your desktop and install it. You should be good to go after that. Hope that helps.  Let me know how it turns out.

If you need a more detailed answer on this, please scroll up and reference my UPDATE response on this thread. Alternatively, you can click the folloing link:">">

Let us know how it goes.

Good Luck!

Re: POD HD300: Unable to update flash memory
by JTSC777 on 2012-11-02 13:52:36.7860

Right after I bought my HD 300 I plunked down 400 bucks on a nice new laptop knowing my old Apple G4 and HP desktop were not going to interface with my Line 6 HD 300-Line 6 M13 and Roland GR-55. Anyone trying to interface these units with older computers with a lot of data stored on them or multiple users will have problems.Thus far I have done all updates to both Line 6 units with no problems at all.Took my sweet time and did them at a place I could focus on the task at hand without distraction.Before I attempted any of them I read the instructions multiple times. Both updated Line 6 units are marvelous now. Being able to turn oiff the modeling with the HD300 enables me to use it with all my single ended non effect loop tube amps.VERY COOL!!! The only problem I had with the HD was not letting monkey do everything on it's own. When I let the monkey take over everything was good. The Monkey Is Your Best Friend.Good Luck!

The information above may not be current, and you should direct questions to the current forum or review the manual.