These forums are read only, please use our new forums here.

Main :: BackTrack / MIDI Mobilizer

New Backtrack +mic not working
by gpurinton on 2012-12-02 18:02:33.9080

I just got a Backtrack +mic, and have not been able to get it to do anything. I connected it to my computer to charge it overnight. When I first turned it on (not connected to the computer) it flashed multicolor lights and then went dark. When I tried to record, no lights came on. When I tried to playback (just in case something did record) nothing happened. When I reconnected it to the computer, the computer detected a new drive, but I cannot open the drive to see any files. When I turn on the Backtrack while connected to the computer, the white light comes on for about 12 seconds, then the light flashes green and red for a second, and goes to white for another 2 seconds before going dark. Now pushing any buttons does nothing. I downloaded the firmware, but can't transfer it to the Backtrack because the computer keeps saying to insert a disk into the device. When I unplug the Backtrack, the device disappears as a device in Windows. I performed a reset, but no lights came on after the 3 second press and release, and there has been no change in behavior.

The information above may not be current, and you should direct questions to the current forum or review the manual.