Jump to content

mkorchia

Members
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by mkorchia

  1. mkorchia

    Amplifi TT for vocals?

    Hi, i'd love to use my Amplifi TT (i'll buy one very soon) as my main soundcard. Also, I'll use it to record vocals. Do it work well with a microphone? Or is there a problem of impedance & a need to go through a mixing desk/preamp/whatever? Also, I'm surprised that in France you can find TT at only 100€ (120$) in some shops, & twice less in some other. Will it be discontinued soon? Thanks! mk
  2. mkorchia

    Amplifi TT for vocals?

    Hi, i'd love to use my Amplifi TT (i'll buy one very soon) as my main soundcard. Also, I'll use it to record vocals. Do it work well with a microphone? Or is there a problem of impedance & a need to go through a mixing desk/preamp/whatever? Also, I'm surprised that in France you can find TT at only 100€ (120$) in some shops, & twice less in some other. Will it be discontinued soon? Thanks! mk
  3. Hi all, I've experienced a problem in the last 10 days or so. Sometimes, I play music in winamp, YT or bandcamp, & the sound suddenly disappears. If I start an "ASIO software" (IE, cubase sx5 or the standalone app of a plugin), the sound works. The only way to get the sound back in Winamp or in my browser is to restart the computer. I've tried to unplug then plug the KB37, to change drivers in Winamp, or to tweak the audio part of the control panel, nothing works. Thanks in advance, mk
×