Jump to content

miller1232

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About miller1232

  • Rank
    Just Startin'

Profile Information

  • Registered Products
    2

Recent Profile Visitors

65 profile views
  1. Posted Yesterday, 05:01 PM I recently purchased the MKII 40W 112 and everything seems to work and sound great. The thing is for the first couple of weeks the display window stayed lit always and the tap button blinked as well. Now the display lights up for about 20 seconds and then fades out.It wakes up when knobs are adjusted except for the master and using the preset to change channels and then fades out again. Is this the way it is suppose to function or is it suppose to remain on. The amp works but because this changed from staying on to not staying on I'm hoping someone can give me a answer because I can't find one in the manuals..Thanks all.
  2. miller1232

    Spider Valve MKII display question

    Thanks my mistake
  3. I recently purchased the MKII 40W 112 and everything seems to work and sound great. The thing is for the first couple of weeks the display window stayed lit always and the tap button blinked as well. Now the display lights up for about 20 seconds and then fades out.It wakes up when knobs are adjusted except for the master and using the preset to change channels and then fades out again. Is this the way it is suppose to function or is it suppose to remain on. The amp works but because this changed from staying on to not staying on I'm hoping someone can give me a answer because I can't find one in the manuals..Thanks all.
×