Jump to content

curtlondon

Members
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by curtlondon

  1. curtlondon

    DT25 Head not responding

    my DT25 head just cuts off and starts making a weird chirping sound. Almost like the sounds an old internet hookup/fax machine used to sound like. Makes the sounds even after I unplug the L6 XLR cable. It seemed to start failing when switching patches on my HD 500X. Got worse with my Helix. Help!
  2. curtlondon

    DT25 Head not responding

    Greatly appreciate your help!
  3. curtlondon

    DT25 Head not responding

    Got the amp July 2016. There were a couple of instances at church when someone turned off power supply before I could properly shut it down. Hasn't worked 100% right in 6 months. I'll have to try the tubes first as shipping it to a dealer would be costly. I do use the recommended digital cable which I thought of replacing but the noises were still happening even after I pulled cable out and restarted amp.
  4. curtlondon

    HD 500X with DT25 head cuts off

    I use a HD 500X with a DT25 head. Has worked great for last 6 months but after a rehearsal at church it stopped responding right when we went onstage to play a second service. Everything lit up but no sound. Unplugged and powered up the 500x....nothing. I had to leave the stage and go turn the amp off and back on. The 500X finally worked. Just had a different band practice and same thing happened. The display started flashing different settings, volume got real low and then came back. I'm perplexed. Am I possibly switching too quickly on presets when trying to find the right one?
×