Jump to content

Maddnesss

Members
  • Posts

    3
  • Joined

  • Last visited

Maddnesss's Achievements

Newbie

Newbie (1/14)

  • Week One Done
  • One Month Later
  • One Year In
  • First Post Rare
  • Conversation Starter Rare

Recent Badges

0

Reputation

  1. Thanks for the replies, been busy but i'll go in a shop soon to make sure it's not something related to guitar components then i'll update this thread hopefully when i find the solution, i tried playing with settings, level input etc & it always sounds like trash. My bro came in with his guitar which is a cheap cort x2 or something, & new cables, it sounded trash aswell so that made it even worse for me, i was hoping it to sound ok so i would know for sure it's my pickups or whatever & just fix it and be done with this. I'm actually scared it could be the babyface which i just bought used ? @colek98 My guitar is an old 400€ cort evlx4 with passives emgs & elixir polyweb, i noticed on helix native that the input level was lower & lower the higher the string i picked so maybe it's related to string height, but i'm not convinced just height would drastically change the sound since even the lower string on itself sounds bad. I'm gonna upgrade eventually to a charvel dk24 but i'm waiting namm show to hopefully have a new model with stainless steel frets, still i would like to know what the problem is first, if i spend 1k & it still sounds bad i'm gonna be pissed. Oh & here's another recording i made before i gave up playing with settings.
  2. Thanks for the reply, do you mean pickups battery ? I thought about that but those emgs are passives version
  3. Hello, i'm having trouble finding a good sound no matter what the preset i choose, even tried ownhammer IR's still sounds so bad, idk how to describe it, thin, muddy, no sustain, weak, warbling, really horrible imo. I've watched plenty of videos & i'm sure the problem isn't the helix. I'm running guitar straight into rme babyface pro & helix native listening through seinnheiser hd598. At this point i'm wondering if it's not the guitar itself that has a ground wiring or pickup problem, i don't have a real amp nor a 2nd guitar & cables to compare unfortunately. The input jack on my guitar is a bit loose & i had that pop sound + background noise when moving it around but it seems to be gone somehow now, still sounds horrible. Pickups are EMG-HZ H4 & EMG-HZ S3 Here's some quick examples where i'm switching pickups & playing with pot : in od exemple on bridge pickup i'm completely losing the distorsion, getting a weak clean signal still. On clean example you can hear the pot at the end making scratchy noises if it means anything ? & the brit plexi one is just how bad it sounds on pretty much all presets. https://soundcloud.com/user-120627922/sets/helix-native/s-Rm24O Thanks for the help.
×
×
  • Create New...