Jump to content

GeeBorg

Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About GeeBorg

  • Rank
    Just Startin'

Profile Information

  • Registered Products
    9

Recent Profile Visitors

84 profile views
  1. Thanks Bentele, Yes , it's firing on all cylinders again. It's such a powerful, versatile beast it would have been a great pity if it had popped its clogs. Cheers, GeeBorg
  2. GeeBorg

    Is Helix compatible with Variax 700

    Silverhead, Thanks for your updated info. I'm certainly glad that there are enthusiasts / experts out there willing to share their knowledge. Tak så mycket igen.
  3. GeeBorg

    Is Helix compatible with Variax 700

    Siverhead, Many Thanks for your prompt reply and the information. The main thing is that I can use the Helix as the interface between my Variax 700 and my DT50 amp which unfortunately lacks the VDI interface of the Vetta II. Appreciate your taking the time to respond. MVH, GeeBorg Silverhead, Thanks for update.
  4. GeeBorg

    Is Helix compatible with Variax 700

    Siverhead, Many Thanks for your prompt reply and the information. The main thing is that I can use the Helix as the interface between my Variax 700 and my DT50 amp which unfortunately lacks the VDI interface of the Vetta II. Appreciate your taking the time to respond. MVH, GeeBorg
  5. GeeBorg

    Is Helix compatible with Variax 700

    Hello Folks, I am considering the purchase of a Helix or a Helix LT and would be grateful if someone could advise whether this would be compatible with a Variax 700 using the VDI cable? MVH GeeBorg
  6. Problem fixed. Guitar technician traced problem to loose connection. Glad to say amp as good as new.
  7. Hello Folks, I would be grateful for any help / advice re the following:- when I plug a guitar into my Vetta II Combo using 1/4" cable no sound forthcoming - the LCD display lights up with everything displayed as expected, however when I plug my Variax into the amp using the Variax digital cable, the sound is perfect. I have experimented with different guitars and 1/4" cables, but no joy. Cannot find an explanation as to why I get sounds with the Variax, but no sounds with my Fender, Burns, PRS etc. Any ideas or someone with a similar experience? Any advice would be most appreciated. MVH, GeeBorg
×