Jump to content

kye90

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About kye90

  • Rank
    Just Startin'
  1. There is no cable connected to this shaver converter that I mentioned. It's just a plug head with a 1A fuse in it. So the EU cable they sent me would get plugged directly into the back of it. So I imagine it would be fine with a 5A fuse in it. After all the hassle I'm not sure it was worth it. I don't think the DT25 is giving me much better tones than I could get out of PodFarm. Tomorrow I'll be working to establish just that; if they're just pretty much the same, and then the amp can go back.
  2. Thanks, I've requested the kettle plug they've offered, and I've ordered some 5A fuses off Amazon. I'm using it with my Blackstar plug at the minute. Is it normal to hear a slight 'buzz' from the tubes? You wouldn't really notice it unless you're behind the amp with your head near the grill, but it's there. Just want to check that it's normal...
  3. I have one of those converter plugs for use with a shaver, that you stick the 2 prong into so you can charge it in a UK 3 prong socket. It says 'Shaver Only' on it, but I'm assuming that's because it only has a 1 amp fuse in it. If I put a 5 amp fuse in there would that be safe to use also? EDIT: Thomann have replied to my e-mail and offered to send me one of these 4 options, but none of them are 5 amps like you've recommended..? http://www.thomann.de/gb/the_sssnake_uk_power_cord.htm http://www.thomann.de/gb/thomann_netzkabel_uk_powercord_3a.htm http://www.thomann.de/gb/thomann_adaptor_eurouk.htm http://www.thomann.de/gb/thomann_traveladaptor_uk.htm
  4. Hi, I ordered a DT25 from a German website and it came today. The problem is that I live in the UK and it doesn't seem to come with a UK plug... I don't know whether the plug included is EU or USA. On the two-pronged end, it says 16A 250v. But on the opposite end, the end that goes into the amplifier, it says 10A 250v. But on the actual DT25 the white sticker below the midi ports says "220 - 230 Volts" So I'm confused as to what to do now. Should I have got a 3 pronged UK plug with it? I would have imagined that would be the case. I don't know anything really about amps and volts. I have another plug from my Blackstar HT Stage 100, which at the 3 pronged end says 5A 250v, and at the other end says 10A 250v. Would that work for now..? Please don't say yes unless you are 100% sure... I've e-mailed the company I bought it from, but I was hoping to maybe get some feedback from people here in the meantime, thanks.
×
×
  • Create New...