Jump to content
  • 0
Sign in to follow this  

Pod Hd500 Crashing My Laptop?


Opps, I originally posted this in the wrong place, I hope I've found the correct home for this question now :)




I'm suffering a lot of crashes  on my Dell M6400 laptop, running with a POD HD500


I used to use this with a pod XT and that was 100% bomb proof :(


Anyways...here's what I'm seeing:


I open up my laptop, plug in the USB from the HD500 fire up the HD500  edit software


This works fine to control and record  the HD500


My problem comes with disconnecting and closing the laptop, I am getting frequent crashes BSOD and memory dump and I have to reboot my laptop. So far I've had this happen on unplugging the USB, Clsoing the HD editor, on re-opening the laptop


So questions:


1) is there a driver update to make this work as well as my POD XT used to

2) if there isn't whats is the correct procedure for closing down and disconnecting the HD from windows


Many thanks for any help!



Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I am having the same issue but with my Desktop PC. My XT Live worked without issue. My issue I am having is that I fire up HD500 Edit and I try to navigate to the Presets (Heavy, Duel Tones etc) and it won't let me pick the drop down.


What has happened a lot lately is that when it crashes it goes into the boot loop and I have to do a Global reset. I had to do that last night about 5 times. I went back to Firmware 2.02 thinking that might help....but, it didn't. I am going to try on my other PC and also on my Laptop and see.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this