Jump to content
Sign in to follow this  
lloyd38

Hd147...impedance...help>>>>

Recommended Posts

Does anyone know about impedance on an hd147 going to a marshall 1960A?? I just got the hd147 yesterday and thought I had it hooked up right. I have been playing on it all day and have had the impedance on the amp set at 8ohms running mono into the 4ohm of my amp. I loved the sound that I had, man it sounded so damn thick. Then I seen I had it wrong.

 

I switched the impedance on the hd147 to 4ohms and it got a lot louder but the sound went to S*hit in a hand basket!

 

I know on most solid state amps the impedance doesn't really make a damn, mis matching it will only lower the output but Im not sure on this digital stuff. 

 

 

Does anyone know if I can mis match the impedance on the hd147? Will it hurt the amp to do that? I want to run it like it was. The amp on 8ohms plugged into the 4ohm on the cab, cause man it sounded like hell hooked up right.

 

PLEASE HELP..........!!!!!!!

 

 

 

Share this post


Link to post
Share on other sites

before anyone spent there time trying to help I Just wanted to say i fixed the problem by just turning down the volume knob DUH!! It would stand to reason the 147 was putting out more volume buy setting the impedance right.So by turning down the volume knob it put me back to where I was before I hooked the amp up the right way right.

 

 

 My dad was wrong. He said I wasn't right but, im also stupid and a bum:) and I like fried chicken. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×