Jump to content
Sign in to follow this  
gordwait

Usb Audio To/from Mac - No Sound Coming Back From Mac..?

Recommended Posts

I've got the latest drivers installed, 

rebooted the Mac as required, and I used Mac preferences to set the audio for the laptop to the m20d choice. 

 

I can see audio coming in to the Mac, but when I play iTunes, nothing seems to come back out from the Mac to the m20d. 

 

I see in the FAQ it tells me I need to add a laptop icon to the stage, and then set levels, but I can't find one that accepts USB. 

 

I have used up the analog audio inputs, and when I try to drag the laptop icon to the stage it tells me 

"No jacks are available that can accommodate this icon."

 

I need a laptop icon with a USB input, but the only one I find has a stereo jack picture attached. 

 

Also, when recording into Logic, I can see the audio in, but at a very low level. 

 

Stuck... Help.. 

 

OSX 10.8.5, 

Line6 m20d driver 1.23

m20d firmware 1.2

 

 

Share this post


Link to post
Share on other sites

Resolved my USB playback issue (and closed the ticket). Once I got it in my head to just use the same Laptop icon for either analog mini jack aux in, or USB stereo in, I was able to make it work. It would have been a bit more intuitive if the laptop icon changed to show a USB plug as opposed to a stereo analog input..

 

The bad news is yes, the USB record latency is huge (at least 1/4 second) making the m20d all but useless as a multitrack interface for a DAW like Logic etc. 

I'll have to keep my old presonus around instead of selling it off as I planned when buying the m20d..

 

Hopefully it's a driver thing, and not a hardware limitation..

 

The record levels thing is on purpose - to give live users lots of headroom, 0db on the M20d meters is -15.4 db "digital", whereas Logic uses 0db as "full scale digital"

so the audio in looks to be at -15.4 db when set to zero on the M20d. 

 

I'm actually ok with this, I changed the Logic metering section to one that shows more detail for lower signal levels: Preferences->Display->Mixer->Level Meters set to "sectional dB linear".  I also set Logic to 24 bit to match the M20d.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×