Jump to content
Sign in to follow this  
Dgmtexas

POD HD500X editor

Recommended Posts

I have 10.13 OS, but I’m getting an error message that POD HD500X editor can’t be installed because it requires OS X 10.5 or  higher

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×