Jump to content
Sign in to follow this  

UX2 not even starting

Recommended Posts

Hello everybody.

I got an old UX2 I got new in 2010. Worked perfectly on an old pc (Windows XP). Never unplugged from it during all these years, until I needed it to work on my MacBook Pro (macOs High Sierra) but the device doesn't even start. The UX2 led keep flashing like it's trying to start, but won't go any further. I downloaded and installed the drivers, did it several times, restarded the Mac, turned off and turned on the Mac, unplugged and replugged the UX2... tried everything. It doesn't work. Finally I got back to the old pc and guess what? The UX2 now doesn't work even on this one!!!!! Time to throw it away? Or there's a chance to bring it back to life?


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...