Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Line6 Helix boot failure


Recommended Posts

Hi there. I am having a problem with my helix.

I have started to update the firmware from version 2.30 to the 3.15 version. I downloaded the latest version of HX Edit. 

I plugged the helix into my Mac loaded up HX edit and followed the update instructions, all was going well until it said update failed try again. I tried again and had the same result, and now I when I turn on the helix I just have to boot failure message on the screen. any help will be appropriated. 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...