Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Pod Go does not boot after 2.0.0 firmware update [RESOLVED - bugs workaround]


Recommended Posts

Pod Go Edit prompted me to update the Pod Go to 2.0.0. I consented.


After update showed complete in Pod Go Edit the unit showed only "Updating..." for 20 minutes, at which point I came here to see that this is a common issue. When I power on the unit normally, it locks up at the POD GO splash screen and shows Firmware 1.40.1.


Attempts to fix using Line6 Updater / DFU mode (Page >):

confirmed that PC has no sleep/hibernate function enabled (it is always on)


reboot Windows 10 machine, and confirm in Task Manager that nothing audio-related is running; in fact nothing is running at all besides Line6 Updater


connected Pod Go to multiple different USB ports on the back of the machine (not hubs or front of machine)


confirmed that no audio hardware is connected to PC


confirmed that Pod Go has no connections besides power and USB


tried two different USB cables


tried Line6 Updater online mode for both 2.0.0 and 1.4.0 and offline mode for 2.0.0 and 1.4.0 (downloaded files)


Line6 Updater always fails. Note that the windows "usb disconnected" sound occurs on the "Update In Progress" screen (first screenshot), immediately after the transition from "Downloading firmware update image" to "Installing firmware update..."


Factory reset (C+D startup) and Clear settings (A+B startup) result in the relevant message on the splash screen but the unit still locks up there.






I had another unused windows 10 machine sitting around, so I did this:

confirmed that nothing is running on the machine at all, besides windows processes


no connections on PC besides power, keyboard, and mouse


downloaded/installed Line6 Updater and Pod Go (latest versions) which include Pod Go drivers


connected Pod Go via USB (no connections on Pod Go besides USB and power)


powered on Pod Go in DFU mode (Page >), windows gave the "usb connected" sound


confirmed in Device Manager that the Line6 device was there; listed as "DFU"


ran Line6 Updater


attempted online install of 2.0.0 firmware: FAIL - same error as the other machine


attempted online install of 1.40.0 firmware: SUCCESS - Pod Go boots up as normal before this fiasco


DON'T TOUCH ANYTHING JUST YET - DON'T CLOSE UPDATER - DON'T TOUCH Pod Go - if you still want to upgrade to 2.0.0 firmware...


As I now knew that I could successfully rollback to 1.4.0, on this specific machine, using this specific process, I decided to try the Line6 Updater again (never closed it from before, never opened Pod Go Edit on this machine at all, never touched the Pod Go unit) to online install 2.0.0 firmware: SUCCESS


Line6, there are definitely some kinks to be worked out. Given my tech-savvy, and spare machine, I'm guessing that a lot of folks aren't willing or able to go through the trial and error that I did. Perhaps some official guide on workarounds (or a software fix) would be in order.





  • Like 1
Link to comment
Share on other sites

  • Nomen00 changed the title to Pod Go does not boot after 2.0.0 firmware update [RESOLVED - bugs workaround]
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...