Jump to content

MustBeWasabi

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About MustBeWasabi

  • Rank
    Just Startin'
  1. Hi, I just bought Pod Farm 2.5 for my MacBook but I cant install it on Yosemite. It says version 10.5 or higher is required. Anyone can help?? greetings
×