Jump to content

gibsonsj

Members
  • Content Count

    17
  • Joined

  • Last visited

Everything posted by gibsonsj

  1. This is probably my problem. I have one of these: https://www.amazon.com/gp/product/B07K59LPDJ/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1 Will that work? Does it matter which (red or black) I use in the helix (left or right)?
  2. I have an old SS Fender Ultra Chorus with a stereo effects loop and a stereo power amp section. I'd like to run the helix in stereo to it. I realize the speakers are close together and the effect will be limited, but up close in my studio I should be able to hear the stereo effect. I've tried multiple setups in multiple ways and I can't get it to work as I think it should. The manual shows the options here: https://www.fmicassets.com/Damroot/Original/10001/OM_leg_gtramp_Ultra_Chorus.pdf For whatever reason this still eludes me. Anyone had any luck with a similar setup? I think this amp is fender's try at the JC120, so if anyone has figured that out it may be the same.
  3. I didn't experience that drop. Are you using a cable like this: https://www.amazon.com/Hosa-STP-201-Insert-Cable-Meter/dp/B000068O1N
  4. I took a chance and got one of these https://www.amazon.com/Hosa-STP-201-Insert-Cable-Meter/dp/B000068O1N to use the work-around posted above. Works GREAT! Unless someone chimes in and informs me otherwise, I don't think I'm missing anything by not buying a dedicated expression pedal.
  5. The more I research vol. pedals and exp. pedals the more confused I've become. I thought Volume Pedals only controlled volume, but I've plugged my Ernie Ball VP Jr into the Exp. 2 jack of my helix lt and I'm able to assign it to a wah pedal as well. Oddly, it seems to function as the wah pedal for some of the helix's wahs, but doesn't for others. Are those blocks that won't work, the blocks that require expression pedals? Why? Will this be a viable work-around? https://www.strymon.net/strymon-tech-corner-3-volume-pedal-as-an-expression-pedal/ For my own understanding can someone explain how they're functionally different? I mean, aren't they both just pots you control with your feet?
  6. This could be a viable work-around. Mind sharing how you're getting those tones with the helix? I'm not quite able to get there. Thanks.
  7. I love this little amp and the sounds I get from it. I'd like to use Helix LT for the effects and to switch amp channels so I can ditch the factory footswitch for the amp. Typically this should be easy, but for some unknown reason Fender used a 7-pin DIN Cable to connect footswitch to amp rather than the standard 1/4" TS or TRS. Is there any way to use Helix LT to control amp channels for this amp?
  8. I may have some more insight. Posting in case someone else has this issue. Reading through the manual of my amp it specifies that to use the Right (stereo) effects return, you must use a TRS cable. The left (mono) only needs a standard TS. Perhaps this is why I'm, having the results I am. Can't check for sure because I don't have a TRS cable, but this seems to shed a little light on things. Thanks again for everyone that chimed in offering help!
  9. Still not getting stereo to this amp. Tried using only "stereo specific" effects as suggested. Stereo to headphones no problem. Must be something with this particular amp.
  10. OK! So dummy plug into the amp input changes things. Now, the left effects return works! And it appears that both speakers are playing, but they are getting the same signal. Panning left and right does nothing. Weirdly, with dummy plug in amp input, now the right effects return doesn't work. I also tried. Both effects returns with both helix outputs and dummy in amp input. Seems to still be same mono signal going to both speakers. I'm way better than I was, nice work! Still I'd like to have a stereo signal going to the amp to really let ping pong delays and panning features shine. If you have any more insight, it's much appreciated.
  11. Yes. No matter which helix output i use, I only get sound out of right speaker. And, only if i plug into the R effects return do I get sound. Either output going into left return of amp yields no sound.
  12. Just tried using both helix outputs as suggested. Still only getting sound out of right speaker.
  13. I have an old solid state crate amp that has a stereo effects loop. I'd like to play my helix through it by plugging into the return of the effects loop. I'm having issues making it work correctly and am at my wits end troubleshooting it, maybe I'm overlooking something simple and someone here can point it out. The effects loop on the amp are: Left (mono) send and return and Right (stereo) send and return. When I plug the helix 1/4" output into the the left (mono) return, I do not get any sound when I play. When I plug the helix output into the right (stereo) return, I do get sound but only out of the right speaker (the amp is a 2x12). Switching the cable to left or right helix output makes no change. Guitar into helix in both examples. If I plug the helix output into the input of the amp, I get sound out of both speakers (lower quality). I'd rather not do this because the amp colors the sound of the helix. I have tested the left f/x loop of the amp with another pedal and plugging guitar directly into amp input and it works as it should, so I know the effects loop is working. Why can't I get the helix to play through the left effects loop? Why when I use the right one is only one speaker getting signal?
  14. Thanks guys. These are helpful ideas and they confirm what I was thinking and make sense. With such a powerful machine I wanted to make sure I wasn't missing something.
  15. Very new Helix LT user here. I know the Helix has a built in looper, but it's functionality seems limited. I have an external (3rd party) looper that I enjoy using and understand I can put it in an effects loop, which I've done and it works as expected. As a new user I'm experimenting with the presets getting a feel for what sounds this thing is capable of. I would like to be able to create a short loop on my external looper and flip through the different presets playing lead licks over the loop. However, as soon as I change presets the external looper is no longer heard. I assume this is because the preset I've changed to does not have an effects loop block at the end of the signal chain. Is that correct? In order to scroll through the presets experimenting with different sounds played over the external looper must I add an effects loop block to the signal chain of each preset I hope to use? If so, is there a way to add blocks to all presets, or must this tediously be done hundreds of times? Lastly, if I'd rather change the presets and have the looped sound (again on the external looper) change with the presets, must each preset then have an effects block added to the beginning of the signal chain. Again, must I add this to every preset?
×
×
  • Create New...